help loss of power - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Performance Discussions Kawasaki Teryx performance discussions.
Engine mods, CDI boxes, exhausts, etc.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 05-17-2011, 11:47 AM Thread Starter
Junior Member
 
Join Date: Feb 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
help loss of power

hey guys i have a 2008 teryx w/vforce clutch and dynatek cdi box. did a compression test and it read 65 AND 120. THIS IS REALLY WEIRD. I HAVE NEVER SEEN THIS BEFORE. my top speed is now 40 and everytime i gas on it, it blows bluish smoke out the exhaust. What are the things i should check for ? i want to say my rings are bad on 1 cylinder. i am really stumped on what to do. My question is what should i put in the motor to enhance the performance and i do not want the 840 big bore kit. Im thinking the standard bore but im on a budget. Ideas would be helpful like maybe web cams with muzzy exhaust and hunterworks jet kit with uni filter? need help here just what combination would be best?
kaptn12 is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 05-17-2011, 06:16 PM
Member
 
Join Date: Apr 2009
Location: santa clara C.A
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
check your valves first.
shady is offline  
post #3 of 16 (permalink) Old 05-17-2011, 07:01 PM
Senior Member
 
KYWILDCATS74's Avatar
 
Join Date: Mar 2010
Posts: 375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Well the bluish smoke tells me the lower compression cylinder is shot.. Maybe check your intake connections or you ran it low on oil.. Or to long between oil changes.. Why against the 840?? You are going to have to punch out your jugs anyway.. It will cost you more to do the standard bore than the 840Regaurdless you will have to at the very least replace pistons,rings, and bore cylinders. I would check all intake connections including the carb boots.. You engine should have not done that unless you water logged it, or poor maintenece, or bad connections. Just saying..

Merlin Motorsports custom Teryx
KYWILDCATS74 is offline  
post #4 of 16 (permalink) Old 05-17-2011, 09:30 PM Thread Starter
Junior Member
 
Join Date: Feb 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
no i haven't waterlogged it or anything. i took my intake boots off it was full of oil on the boots. im gonna get some plenum rings and a siphon break. but i tore down the cylinder that was reading 120 psi i didnt find anything out of wack cylinder piston was good. Could a stuck or bent valve cause this? im stumped now Could the oil ring go bad and not scar up the cylinder?
kaptn12 is offline  
post #5 of 16 (permalink) Old 05-17-2011, 10:21 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
The cylinder with 120 is the odd one, normal compression is 45 to 65 or somewhere there abouts due to having a decompression mechanism.

Once runnning though both are gonna be about the same, I would say the one with 120 has a messed up decompression mechanism.

As for the smoke, it is pushing it into the plenum.

I really don't think you have something bad wrong.
Hunterworks is offline  
post #6 of 16 (permalink) Old 05-17-2011, 10:26 PM Thread Starter
Junior Member
 
Join Date: Feb 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
yes 120 psi is very strange exactly what is the decompression mechanism is that on the camshaft? but would this cause me to have no top end wot it goes about 42 it seems like the motor would not rev up b4 this it would hit 57
kaptn12 is offline  
post #7 of 16 (permalink) Old 05-18-2011, 05:52 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by kaptn12 View Post
yes 120 psi is very strange exactly what is the decompression mechanism is that on the camshaft? but would this cause me to have no top end wot it goes about 42 it seems like the motor would not rev up b4 this it would hit 57
There is a mechanism on the camshafts that pushes a pin up and allows the exhaust valve to open some during start up so compression is not so high making it easy to turn over. Once started centrifugal force makes these two weights fly out turning a small shaft inside the cam pulling the pin back in.

The lower pressure one is right on, the 120 one is the one with the issue.

But as I mentioned it really should not matter because once running the lower psi cylinder would be up to the higher.

As to what is causing your issue, I would need lots more information
Hunterworks is offline  
post #8 of 16 (permalink) Old 05-18-2011, 06:31 AM Thread Starter
Junior Member
 
Join Date: Feb 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
We noticed the mechanism on the camshaft was engaged when we were tski g the camshaft off so we manually disengaged it. Dk if it's supposed to be engaged or not? But what other info would u like to know. The sooner I solve this the better because I'm ready to order parts n I'll be ordering from u like ur carb kit rings stop kit muzzy exhaust. Thanks for ur help
kaptn12 is offline  
post #9 of 16 (permalink) Old 05-18-2011, 06:20 PM
Senior Member
 
KYWILDCATS74's Avatar
 
Join Date: Mar 2010
Posts: 375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by kaptn12 View Post
We noticed the mechanism on the camshaft was engaged when we were tski g the camshaft off so we manually disengaged it. Dk if it's supposed to be engaged or not? But what other info would u like to know. The sooner I solve this the better because I'm ready to order parts n I'll be ordering from u like ur carb kit rings stop kit muzzy exhaust. Thanks for ur help
Well I didnt realized it began smoking after you climbed a hill or revved it hard and long.. That will cause one to fill your air cleaner with oil blown out of your crankcase. The mechanism should be engaged until your engine runs and centrifical force dissengages it..Did you check your plugs, did it have any miss or rough running?

Merlin Motorsports custom Teryx
KYWILDCATS74 is offline  
post #10 of 16 (permalink) Old 05-18-2011, 09:46 PM
Member
 
Join Date: Apr 2009
Location: santa clara C.A
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
My 08 smoked the first time out( Oil in the plenium ) no biggie, but I said check valves first, because it is free and easy. Todd will take care of you he has played with these engines for a while now he knows whats up.
shady is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Loss of speed and power nate177 Kawasaki Teryx General Discussions 22 01-15-2013 01:49 AM
coolant loss? rockfish Kawasaki Teryx General Discussions 9 03-10-2010 04:39 PM
08 Teryx LE power loss jeryx Kawasaki Teryx General Discussions 0 11-15-2009 03:58 PM
Teryx Power Loss rodleague Kawasaki Teryx General Discussions 5 09-10-2009 07:55 AM
Antifreeze loss jcummins Kawasaki Teryx General Discussions 4 12-02-2008 08:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66