Flickering HID's - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Electrical Discussions Kawasaki Teryx electrical discussions.
Lighting, audio, GPS, communications, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-12-2009, 06:45 PM Thread Starter
Senior Member
 
Join Date: Nov 2008
Location: LA
Posts: 144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Flickering HID's

What could cause HID's to flicker like strobe lights? They alternate from left to right for awhile when first turned on and you would think it was a police or emergency vehicle.

'08 Teryx- Dyna CDI & Coils, HW Jet kit w/ TPI valves, Dalton clutch & OD plate, HID's, Muzzy's, FST 840, UNI, 4 Seat Cage, WER Shocks, 27" Bighorns & 29.5 Outlaws
dirtracer4 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-12-2009, 07:13 PM
Senior Member
 
Join Date: Jan 2009
Location: Long Beach, Ca
Posts: 158
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Bad Ballast
efajeep is offline  
post #3 of 6 (permalink) Old 09-12-2009, 10:18 PM
Senior Member
 
SXSCustoms's Avatar
 
Join Date: Aug 2008
Posts: 630
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by dirtracer4 View Post
What could cause HID's to flicker like strobe lights? They alternate from left to right for awhile when first turned on and you would think it was a police or emergency vehicle.
Are they direct plug and play meaning no relay?

Also not enought battery volts to fire the second one off.

Or bad ballast....
SXSCustoms is offline  
 
post #4 of 6 (permalink) Old 09-13-2009, 07:58 AM Thread Starter
Senior Member
 
Join Date: Nov 2008
Location: LA
Posts: 144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
yes P&P, I'll charge the battery and see if that helps. I remembered that I did try to turn the lights on when the bulbs were disconnected once. Could this have damaged the ballasts?

Thanks for the replies

'08 Teryx- Dyna CDI & Coils, HW Jet kit w/ TPI valves, Dalton clutch & OD plate, HID's, Muzzy's, FST 840, UNI, 4 Seat Cage, WER Shocks, 27" Bighorns & 29.5 Outlaws
dirtracer4 is offline  
post #5 of 6 (permalink) Old 09-13-2009, 10:15 AM
Senior Member
 
SXSCustoms's Avatar
 
Join Date: Aug 2008
Posts: 630
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by dirtracer4 View Post
yes P&P, I'll charge the battery and see if that helps. I remembered that I did try to turn the lights on when the bulbs were disconnected once. Could this have damaged the ballasts?

Thanks for the replies
No porb... also I forgot make sure you have a good ground. Some ballast get funky after a while.

If you anymore issue call me Ill help you out.
SXSCustoms is offline  
post #6 of 6 (permalink) Old 09-13-2009, 10:06 PM
Junior Member
 
Join Date: Apr 2009
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
i had the same problem, my teryx seemed a "discotheque". i checked the battry and it was at 8 volts!
i charged the battery and probem solved.
EL INMORALISTA is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HID's vs LED Lightbar dieselpowered Kawasaki Teryx Electrical Discussions 6 04-02-2008 07:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88