Keeps popping fuses!! - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Electrical Discussions Kawasaki Teryx electrical discussions.
Lighting, audio, GPS, communications, etc.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 03-27-2010, 08:42 PM Thread Starter
Junior Member
 
Join Date: Nov 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Keeps popping fuses!!

Hey guys i've been having problems with the main fuse popping. Before it would run for a while and the just turn off. So I would switch the fuse and go again.(i know its not right)now its got to the point where even if its off I go to put a new fuse in it just pops. I need some help 30 fuses and still no luck. Its a 2009 Fi teryx (monster edition) if that madders.

Thanks Guys
indiocyclesupply is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 03-27-2010, 09:03 PM
TeryxHQ.com Staff Member
 
DougS's Avatar
 
Join Date: Apr 2008
Location: Alberta, Canada
Posts: 2,107
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Do any recent wiring?
DougS is offline  
post #3 of 11 (permalink) Old 03-27-2010, 09:04 PM Thread Starter
Junior Member
 
Join Date: Nov 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by DougS View Post
Do any recent wiring?

Nope bone stock.
indiocyclesupply is offline  
 
post #4 of 11 (permalink) Old 03-27-2010, 09:43 PM
TeryxHQ.com Staff Member
 
DougS's Avatar
 
Join Date: Apr 2008
Location: Alberta, Canada
Posts: 2,107
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
I had that happen on the brute force . A positive line was grounding out and thus blowing fuses.
DougS is offline  
post #5 of 11 (permalink) Old 03-27-2010, 09:49 PM
Build Sponsor
 
SandJunkie's Avatar
 
Join Date: Apr 2008
Location: Bumfuque, CA
Posts: 796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by DougS View Post
I had that happen on the brute force . A positive line was grounding out and thus blowing fuses.
Thats what it sounds like to me...
SandJunkie is offline  
post #6 of 11 (permalink) Old 03-28-2010, 06:52 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Take back to dealer and let them figure it out.



Hunterworks is offline  
post #7 of 11 (permalink) Old 03-28-2010, 10:07 AM Thread Starter
Junior Member
 
Join Date: Nov 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Hunterworks View Post
Take back to dealer and let them figure it out.
Thats what I was gonna do but I need it by Thursday and I know there gonna take there sweet ass time with it. Im gonna check it out when i get home later today.
indiocyclesupply is offline  
post #8 of 11 (permalink) Old 03-29-2011, 01:38 PM
Junior Member
 
Join Date: Aug 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Did you find out what was popping that fuse as mine is doing the same let me know please Rob
rb0475 is offline  
post #9 of 11 (permalink) Old 03-29-2011, 06:09 PM
Senior Member
 
SXSCustoms's Avatar
 
Join Date: Aug 2008
Posts: 630
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by rb0475 View Post
Did you find out what was popping that fuse as mine is doing the same let me know please Rob
Need more info... feel free call after 7 pm PACIFIC...
SXSCustoms is offline  
post #10 of 11 (permalink) Old 05-08-2011, 04:25 PM
Junior Member
 
Join Date: May 2011
Location: Barbers Hill
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Hey did yall ever figure out what the problem was with the main fuse blowing. Went to a fourwheeling event this past weekend and main fuse is now popping. Before it blew I had sprayed off the radiator since it was overheating and went out on the trail and it lost all power. Only things I have done are installed an Odyssey 1200 battery, a winch, and stereo. Any help appreciated.
mud reaper is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
the dreaded popping at idle gantt425 Kawasaki Teryx Performance Discussions 4 02-20-2010 06:37 PM
Decel Popping brettrown Kawasaki Teryx Performance Discussions 21 02-03-2009 07:47 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89