Another cooling fan issue - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Electrical Discussions Kawasaki Teryx electrical discussions.
Lighting, audio, GPS, communications, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 08-18-2010, 10:53 AM Thread Starter
Junior Member
 
Join Date: Aug 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Question Another cooling fan issue

I have a similar problem with my 08 Teryx cooling fan. It keeps running until I disconnect the batt and wait a few minutes, reconnect the battery and it is fine till my next ride. Is the problem with the fan sw (27010-0091) or the sw sensor water (27010-1346) that is the culprit. Is there a way to test which is causing the problem. I found both parts available online. What advantage is there to use the kit mentioned to solve the problem.
jacuba is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 08-18-2010, 02:59 PM
Senior Member
 
Join Date: Jan 2009
Location: Sugar Land, TX
Posts: 104
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I am sure someone will correct me if I am wrong. The fan is supposed to keep running when the key is off. The circuit for the fan is live no matter what the position of the key is. Try letting the fan run and see if it turns off on its own once it cools off. I know mine does.
JAKE JANACEK is offline  
post #3 of 10 (permalink) Old 08-18-2010, 04:09 PM
Senior Member
 
Join Date: Nov 2009
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
This happened to mine once...its supposed to run until its cool after the key is off...i tapped the sensor thats attached to the radiator on the driver's side with the handle of a screw driver and its worked fine ever since...i guess it was stuck or something...i'm still on the fence about adding a water temp gauge and a switch just to backup the system...because i dont trust it...if it can stick on, it can stick off and cause the fan to not come on at all.
Gr3G is offline  
 
post #4 of 10 (permalink) Old 08-18-2010, 07:52 PM Thread Starter
Junior Member
 
Join Date: Aug 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Yes normally the fan would run with the ig sw off for a couple of minutes after riding in hot weather and then shuf off, but lately it keeps running and running even though the weather is cooler. It ran for 15 minutes the other day until I disconnected the battery. I hooked the battery back up five minutes later and the fan did not run. I have never had to add coolant and its on the full mark. I have about 1,400 mi on it.
jacuba is offline  
post #5 of 10 (permalink) Old 08-19-2010, 05:26 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Probably temp switch



Hunterworks is offline  
post #6 of 10 (permalink) Old 08-23-2010, 02:30 PM
Senior Member
 
Join Date: Mar 2009
Location: Salem, OR
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
The fan runs until cool even without the key in. If you have to disconnect the battery to get it to shut off then you are heading the same way I was. at first it will shut aff after you reconnect the battery, but after a few times it will always stay on. I just did Todd's kit (Hunterworks) and have had no problems since the install! Ran the hell out of this past week in the Dunes and ran without a problem.
atv4fun is offline  
post #7 of 10 (permalink) Old 08-24-2010, 01:49 AM
Moderator
 
tomanytoysnotnuftime's Avatar
 
Join Date: Jun 2008
Location: Fort Saskatchewan, Alberta, Canada
Posts: 383
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by jacuba View Post
I have a similar problem with my 08 Teryx cooling fan. It keeps running until I disconnect the batt and wait a few minutes, reconnect the battery and it is fine till my next ride. Is the problem with the fan sw (27010-0091) or the sw sensor water (27010-1346) that is the culprit. Is there a way to test which is causing the problem. I found both parts available online. What advantage is there to use the kit mentioned to solve the problem.
Needs a new switch. Try tapping the switch next time the fan stays on, and it will turn off. Keep taping it instead of disconnecting the battery until you replace it.

2012 VIBRANT Blue Teryx 4, Muzzy pro's, ECU reflash, custom cage & roof, windshield, 14" STI HD Beadlocks & 32x10x14 STI Roctane's/Tatou 4S Tracks, Rigid Lights, Custom bumpers, Warn XT4000 winches front & rear, bedlift

2010 black, FST 840 stage II cams, DASA intake & injectors, BF throttle bodies, Msd, Muzzy Pro`s, Snorkeled, Warn XT 4000, EMP, 2 seat race cage, Custom rear Radiator, Unisteer, STI HD beadlocks and 30x10x14 EFX motoclaws
tomanytoysnotnuftime is offline  
post #8 of 10 (permalink) Old 11-03-2010, 02:57 PM
Junior Member
 
Join Date: Sep 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
i have a 2009 and when i turn the ignition off the fan turns off as well. Is this normal or should it stay on until the temp switch shuts it off?
scff1781 is offline  
post #9 of 10 (permalink) Old 11-04-2010, 06:36 AM
eez
Senior Member
 
Join Date: Apr 2010
Posts: 318
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by scff1781 View Post
i have a 2009 and when i turn the ignition off the fan turns off as well. Is this normal or should it stay on until the temp switch shuts it off?
mine shuts off with key as well, it will run with key in on position bike not running but turn off and fan shuts off, wondering now if this is coorect?? If not whatcha think is culprit
eez is offline  
post #10 of 10 (permalink) Old 11-04-2010, 09:43 AM
Senior Member
 
Join Date: May 2010
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
My 2010 Sport does the same thing....I'll keep on eye on it but I know it's been running with the key on, then turn the key off and it stops.
shanny55 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
cooling fan breaker crab Kawasaki Teryx Electrical Discussions 5 07-08-2010 10:43 AM
Cooling Fan Issues !! TeryxMasher Kawasaki Teryx General Discussions 4 01-06-2010 09:57 PM
Cooling Fan Issues !!!! TeryxMasher Kawasaki Teryx Electrical Discussions 3 12-27-2009 09:51 PM
cooling the teryx codyo Kawasaki Teryx General Discussions 9 12-18-2009 07:10 PM
Cooling fan won't shut off! Junior Kawasaki Teryx Electrical Discussions 0 07-23-2009 09:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88