HID connectivity issue - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Electrical Discussions Kawasaki Teryx electrical discussions.
Lighting, audio, GPS, communications, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 09-22-2010, 08:33 PM Thread Starter
Senior Member
 
Join Date: Nov 2008
Posts: 780
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
HID connectivity issue

ok, so here is my problem. I have a set of HIDs from Kyle Brown lighting. I like the set, they work fine. I run two different body kits and want HIDs in both so I need another set of bulbs. However, I cant get their phone number from the site and no one replies to any form of email.
Biggest problem is there are 3 plugs as shown in the picture below. What I need is a set of bulbs that will work with these ballasts. I like this set because its the small digital ones. Any help?

2008 Teryx

Something to Tinker with

PM me if you are looking for a Service Manual.
sleepy23 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-22-2010, 08:40 PM
Senior Member
 
SXSCustoms's Avatar
 
Join Date: Aug 2008
Posts: 630
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by sleepy23 View Post
ok, so here is my problem. I have a set of HIDs from Kyle Brown lighting. I like the set, they work fine. I run two different body kits and want HIDs in both so I need another set of bulbs. However, I cant get their phone number from the site and no one replies to any form of email.
Biggest problem is there are 3 plugs as shown in the picture below. What I need is a set of bulbs that will work with these ballasts. I like this set because its the small digital ones. Any help?
I have those bulbs and you know how to get a hold of me.
SXSCustoms is offline  
post #3 of 7 (permalink) Old 09-22-2010, 09:28 PM
Senior Member
 
4x4pac's Avatar
 
Join Date: Nov 2008
Location: Southern Illinois
Posts: 174
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Not to jack a thread but, I was wondering how many of these HID kits that say they are true plug and play really are? Also how many of them have low and high beam?


2009 Teryx LE FI
REAL OFF ROAD RIDERS DON'T RIDE WITH FLEAS
4x4pac is offline  
 
post #4 of 7 (permalink) Old 09-23-2010, 05:59 AM
Senior Member
 
pit dog's Avatar
 
Join Date: Feb 2010
Posts: 311
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Bought a set of egale eyes true plug and play 120 shipped . Install was a snap lighting is crazy.
pit dog is offline  
post #5 of 7 (permalink) Old 09-23-2010, 08:44 AM
Junior Member
 
freedomcell's Avatar
 
Join Date: Jul 2010
Location: SLC, UT
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Garage
Quote:
Originally Posted by pit dog View Post
Bought a set of egale eyes true plug and play 120 shipped . Install was a snap lighting is crazy.
x2, my eagle eyes plug and play as well, but there is no high/low change on the beams... sorry for the thread jack

2010 Teryx
27 inch Bighorns on ITP SS212's
Sandworks Rear Cage, Eagle Eye HIDs, Venom 4500 winch[SIGPIC]
freedomcell is offline  
post #6 of 7 (permalink) Old 09-23-2010, 10:39 AM
Senior Member
 
SXSCustoms's Avatar
 
Join Date: Aug 2008
Posts: 630
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by 4x4pac View Post
Not to jack a thread but, I was wondering how many of these HID kits that say they are true plug and play really are? Also how many of them have low and high beam?
Our kits are TRUE Plug and Play with Hi/Low HID, we also include mounting plates, relay harness, and install instructions.
SXSCustoms is offline  
post #7 of 7 (permalink) Old 09-24-2010, 08:38 AM
Senior Member
 
Join Date: Mar 2009
Location: Salem, OR
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by SXSCustoms View Post
Our kits are TRUE Plug and Play with Hi/Low HID, we also include mounting plates, relay harness, and install instructions.
they also have pictures for those of us that can't read!
atv4fun is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another cooling fan issue jacuba Kawasaki Teryx Electrical Discussions 9 11-04-2010 09:43 AM
brake issue???????? badlime09teryx Member Introductions 5 07-22-2010 08:17 PM
Got a new issue, uaqsports Kawasaki Teryx Performance Discussions 8 11-09-2009 11:17 AM
4x4 issue maybe? Mayo304 Kawasaki Teryx General Discussions 3 11-02-2009 07:13 PM
Heat issue.. rednekexprez Kawasaki Teryx Performance Discussions 0 06-04-2008 01:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89