Still having Dalton Clutch adjustment Problems. - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx General Discussions General discussions pertaining to the Kawasaki Teryx.
Maintenance, cleaning, etc.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 04-04-2009, 03:32 PM Thread Starter
 
Join Date: Dec 2008
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Still having Dalton Clutch adjustment Problems.

So as most of you know I have not been happy with my clutching problems. I had my dealer install the Dalton kit and it has not worked very well since they finished it. Please understand I don't think that the Dalton kit is the problem. Come to find out that they used the STOCK primary spring and now I don't know if the secondary spring is the STOCK or the Dalton Spring. So is the shiny silver one the stock spring or is it the dull silver with white paint the stock one????????

I think I need to change the spring and I think I need to take the small shim out. The reason is I set up the Primary clutch to the exact specs from Dalton and went to the Kawi dealer and raced a stock Teryx and got spanked and I mean spanked!!!!!!!! So would my 1 1/2" deflection belt cause that or is secondary spring causing that????????

I just need help. Any opinions would be greatly appreciated. Also, please understand I do relize the help that I have previously had and I am grateful!!!!!!!!!
Cuzin Eddie is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 04-04-2009, 03:46 PM
TeryxHQ.com Staff Member
 
DougS's Avatar
 
Join Date: Apr 2008
Location: Alberta, Canada
Posts: 2,107
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Have you emailed Dale (Helix) at Dalton yet?
I think your belt could be tighter.
Did the dealer "pull on over your eyes" and charge you for a cheaper clutch kit or by mistake installed the wrong one?

Here is a picture of thier kit from Dalton
Link to Dalton

As per spanked.
Have you added a bunch of weight to your Teryx. (ie cage, 4 seats, etc?)
Both have same mods?

Metal and white line is a Brute Force 650 spring. I think they may have put the wrong kit in.

Scroll down on the link I sent you.

Last edited by DougS; 04-04-2009 at 03:53 PM. Reason: Added more details
DougS is offline  
post #3 of 18 (permalink) Old 04-04-2009, 03:46 PM Thread Starter
 
Join Date: Dec 2008
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Understand though that even with the belt having to much deflection it does not seem to slip. The thing that I did notice is the jerking of the Secondary Clutch. If you give it a little throttle the secondary clutch jumps and jerks.
Cuzin Eddie is offline  
 
post #4 of 18 (permalink) Old 04-04-2009, 03:59 PM
TeryxHQ.com Staff Member
 
DougS's Avatar
 
Join Date: Apr 2008
Location: Alberta, Canada
Posts: 2,107
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Added more stuff to the post above. Did you see the spring by the 650? Is that the one you have?
DougS is offline  
post #5 of 18 (permalink) Old 04-04-2009, 04:39 PM Thread Starter
 
Join Date: Dec 2008
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by DougS View Post
Have you emailed Dale (Helix) at Dalton yet?
I think your belt could be tighter.
Did the dealer "pull on over your eyes" and charge you for a cheaper clutch kit or by mistake installed the wrong one?

Here is a picture of thier kit from Dalton
Link to Dalton

As per spanked
Have you added a bunch of weight to your Teryx. (ie cage, 4 seats, etc?)
Both have same mods?

Metal and white line is a Brute Force 650 spring. I think they may have put the wrong kit in.




Scroll down on the link I sent you.
Dougs

Hard to tell by the pictures on the spring, however I do have a 4 seat cage and some other heavier stuff.

thanks for the info!!!!!!
Cuzin Eddie is offline  
post #6 of 18 (permalink) Old 04-05-2009, 10:29 AM
Senior Member
 
poflo's Avatar
 
Join Date: Apr 2008
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Cuzin Eddie View Post
Understand though that even with the belt having to much deflection it does not seem to slip. The thing that I did notice is the jerking of the Secondary Clutch. If you give it a little throttle the secondary clutch jumps and jerks.
If you you have too much belt deflection,it is like trying to start in a higher gear,the primary clutch is engaged at a higher ratio,when it takes the slack out of the belt;if your secondary spring is too weak,that sometimes signals that the belt is slipping in the secondary pulley by by jerky motion.;which can be caused by trying to take off in the effective higher gear ratio that was created by the loose belt .Sounds like you have more than one problem
poflo is offline  
post #7 of 18 (permalink) Old 04-05-2009, 01:58 PM Thread Starter
 
Join Date: Dec 2008
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Last night I took the Secondary clutch apart and took the thin shim out and put the Dalton spring in since the dealer had accidentally put the stock spring back in. All I can say is WOW on what a diff it made on where the belt rides on the Secondary clutch now compared to where it was before and to think that that small shim made that much difference.

I have not driven it yet... I will tomorrow and let everyone know the difference. All I can say is I am so glad (for now) that I attempted to do this adjustment myself and to learn from all the knowledgeable people here on this forum. I am truly grateful for all the insight that you good people have offered to me.

Thanks again-

Shane
Cuzin Eddie is offline  
post #8 of 18 (permalink) Old 04-05-2009, 08:54 PM Thread Starter
 
Join Date: Dec 2008
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Okay, so I just got a wild hair and took the Teryx out for a small ride it was killing me to see if the adjustments worked. I still don't have the throttle response that I want. It probably takes about 1 to 1 1/2 secs to engage. I definitely have the belt right and I have the amber spring in the Primary and the silver in the secondary. I have alum rivets and I have 2 set screws. It also seems that the RPM's are much higher when it engages.

Why does it take so long for it to engage????? Do I need to change the Primary spring to Orange or do I need to take some screws out or add one?????

Dang it.... now it is getting frustrating
Cuzin Eddie is offline  
post #9 of 18 (permalink) Old 04-05-2009, 09:13 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
I think you need all set screws in for a stock motor.

Takes so long to engage?? Are you easing on the gas?

Hit it and go!!



Hunterworks is offline  
post #10 of 18 (permalink) Old 04-05-2009, 09:17 PM Thread Starter
 
Join Date: Dec 2008
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Hunterworks View Post
I think you need all set screws in for a stock motor.

Takes so long to engage?? Are you easing on the gas?

Hit it and go!!
HW-

No I am hitting it hard. It just when I punch it takes a little while before anything happens. maybe that is the nature of the Teryx. I never rode it stock. Do they tend to have a little delay before they take off???????

At my elevation Helix said I may need 1 set screw. I am at 5,300 ft. Do I need to take the big shim out and put the little one back in???????


By the way I need to order a lift kit from you. I will call tomorrow.

Thanks HW!!!!!
Cuzin Eddie is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Teryx clutch kits Dalton or EPI ? Blurryvision Kawasaki Teryx Performance Discussions 71 09-12-2010 04:04 PM
Dalton Clutch Kit helix Kawasaki Teryx Performance Discussions 23 07-07-2010 08:58 PM
Dalton clutch tuning BRET901 Kawasaki Teryx Performance Discussions 14 01-05-2009 03:22 PM
winner of Dalton Clutch 4ever Kaw-Man Kawasaki Teryx Performance Discussions 2 12-06-2008 06:17 AM
Dalton clutch aviablie RomDOGG Kawasaki Teryx Performance Discussions 8 11-17-2008 10:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89