Engine miss and the prog. CDI??? - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx General Discussions General discussions pertaining to the Kawasaki Teryx.
Maintenance, cleaning, etc.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 36 (permalink) Old 04-22-2009, 06:37 AM Thread Starter
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Engine miss and the prog. CDI???

Does anyone have the engine miss and the programmable Dynatek?

If you do have the programmable and the miss do you have our curve in it?

Trying to figure out the root of the miss.

Todd



Hunterworks is offline  
Sponsored Links
Advertisement
 
post #2 of 36 (permalink) Old 04-22-2009, 03:13 PM
Senior Member
 
jcummins's Avatar
 
Join Date: Apr 2008
Location: Creal Springs, IL
Posts: 193
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Hunterworks View Post
Does anyone have the engine miss and the programmable Dynatek?

If you do have the programmable and the miss do you have our curve in it?

Trying to figure out the root of the miss.

Todd
Todd did you ever find any less expensive coils for the Teryx?
jcummins is offline  
post #3 of 36 (permalink) Old 04-22-2009, 06:48 PM
Build Sponsor
 
DRAGONFIRERACING's Avatar
 
Join Date: Jul 2008
Location: Mesa AZ
Posts: 451
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Ya we ran into miss problems to Hot Coils fixed it
DRAGONFIRERACING is offline  
 
post #4 of 36 (permalink) Old 04-22-2009, 07:25 PM
 
Join Date: Apr 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by DRAGONFIRERACING View Post
Ya we ran into miss problems to Hot Coils fixed it
Do you have a link to these coils? Also did you rejet? Just bought a 08 with CDI Dyna, and Exhaust and clutch kit but seems to miss badly. I'm at 3300Ft any suggestions?
Revolution is offline  
post #5 of 36 (permalink) Old 04-22-2009, 07:36 PM Thread Starter
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
I'm trying something totally different but not sure if it will happen or not.

I want to find out if taking the timing down a notch or two with a programmable one fixes the miss.

Too much timing at part throttle would cause a miss for sure.

Todd



Hunterworks is offline  
post #6 of 36 (permalink) Old 04-22-2009, 10:43 PM
TeryxHQ.com Staff Member
 
DougS's Avatar
 
Join Date: Apr 2008
Location: Alberta, Canada
Posts: 2,107
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Quote:
Originally Posted by Hunterworks View Post
I'm trying something totally different but not sure if it will happen or not.

I want to find out if taking the timing down a notch or two with a programmable one fixes the miss.

Too much timing at part throttle would cause a miss for sure.

Todd

On my Brute Force running Premium fuel and a VDI I could only run about 6 degees advance without issues. Are people running regular gas and having the issue? As I had to pull back about 2 more degrees then too.
DougS is offline  
post #7 of 36 (permalink) Old 04-22-2009, 10:54 PM
Member
 
Join Date: Jun 2008
Location: Lake Havasu
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Todd back on April 10th I chased this down... look at the thread titled: "This is why the Dynatek misses" I posted my coil resistances, fuel tinkering and then all 4 curve tests I did. That's why I have been trying to load your curve. I believe curve 2 is too aggressive on timing advance at lower RPM.

Curve 2 pops and your tech article says curve 2 is the same as what they load in the non-programmable version... it just all adds up and makes sense to me.

So, do you use a USB to serial converter when you use curvemaker? Do you use Vista or XP? right now it's telling me "no ignition found" which is a COM problem but I know my settings and COM port are correct, just wondering if Vista is hosing me.
teryxpilot is offline  
post #8 of 36 (permalink) Old 04-23-2009, 03:35 AM
Senior Member
 
Magellan's Avatar
 
Join Date: Jun 2008
Location: Western, NC
Posts: 1,029
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by DRAGONFIRERACING View Post
Ya we ran into miss problems to Hot Coils fixed it
I did the coils as well, but very little difference, until I got the jetting and needles right.

2011 Teryx Sport
2011 50" STD RZR LE
Magellan is offline  
post #9 of 36 (permalink) Old 04-23-2009, 07:11 AM Thread Starter
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Quote:
Originally Posted by teryxpilot View Post
Todd back on April 10th I chased this down... look at the thread titled: "This is why the Dynatek misses" I posted my coil resistances, fuel tinkering and then all 4 curve tests I did. That's why I have been trying to load your curve. I believe curve 2 is too aggressive on timing advance at lower RPM.

Curve 2 pops and your tech article says curve 2 is the same as what they load in the non-programmable version... it just all adds up and makes sense to me.

So, do you use a USB to serial converter when you use curvemaker? Do you use Vista or XP? right now it's telling me "no ignition found" which is a COM problem but I know my settings and COM port are correct, just wondering if Vista is hosing me.
Software won't work with Vista, sorry.

What did it do on curve one?



Hunterworks is offline  
post #10 of 36 (permalink) Old 04-23-2009, 10:15 AM
Build Sponsor
 
DRAGONFIRERACING's Avatar
 
Join Date: Jul 2008
Location: Mesa AZ
Posts: 451
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
We found it missing at the bottom to mid range we fixed it by running hot-coils in conjunction with our CDI, intake, jet kit, and exhaust. Our jet kit comes with 11 main jets so you can tinker with elevation.
DRAGONFIRERACING is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
FINALLY...Cure for the DYNATEK engine miss!!!! dbmachine Kawasaki Teryx Performance Discussions 22 04-14-2009 09:04 AM
Update: Dynatek CDI Engine Miss dbmachine Kawasaki Teryx Performance Discussions 22 04-06-2009 08:34 PM
dynatech engine miss jaici08 Kawasaki Teryx Performance Discussions 22 03-24-2009 06:37 AM
Hi from SW Miss - looking for prices rodneygt Member Introductions 7 11-30-2008 03:58 PM
Dyna CDI and Engine miss Hunterworks Kawasaki Teryx Performance Discussions 10 06-28-2008 09:21 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89