teryx Trouble - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx General Discussions General discussions pertaining to the Kawasaki Teryx.
Maintenance, cleaning, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-16-2009, 05:16 PM Thread Starter
Junior Member
 
Join Date: Apr 2009
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
teryx Trouble

Looking for some input. I was wondering if anyone has had trouble with the front cylinder on there Teryx. My T-rex is misfiring or popping bad through th Carb on the front cylinder only off idle. The problem was amplified by the changes i've made to the engine. I installed a DynaJet carb kit,Dynatek ignition box, Muzzy Exhaust and a Dalton cluch kit. Any suggestions would be Welcome.
TREX RIDER is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-16-2009, 05:55 PM
Member
 
Join Date: Jun 2008
Location: Lake Havasu
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
here's some history

http://www.teryxhq.com/forums/kawasa...hlight=popping


More info than you want to sort through probably but basically if you bought the non-programmable Dynatek it's probably gonna pop with those mods unless you buy different coils... my laptop at home runs Vista and won't work with Dynatek's software so until I have a long weekend and a loaner laptop I won't be playing with the timing curves but I will find a setting that eliminates the pop... some day.
teryxpilot is offline  
post #3 of 9 (permalink) Old 06-16-2009, 07:19 PM
Senior Member
 
Junior's Avatar
 
Join Date: Jul 2008
Location: Alberta, Canada
Posts: 516
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
teryxpilot,
Did you ever get the #2 timing curve from Todd and did it pop also? Just wondering if this fixed it all, I have the non-programmable dynatek and no problems, but I have a Muzzy system coming and doing some engine work. Just wondering if I may have a problem with my dynatek? May have to get a new one off of Hunterworks...?

27" XTR's on ITP SS212 Chrome 14's
Dynatek N.P.
FST Standard Bore
Dalton Clutch Kit w/O.Drive
Muzzy's - ceramic coated
SDR Deluxe Cage w/roof
SDR Front Bumper w/winch
Twisted Stitch Vortex Front Heated Seats
Twisted Stitch Vortex Rear Heated Bench
Beautiful Lowered Seat Bases by SDR - Thanks!
Crow 5-point harnesses (x5)
Junior is offline  
 
post #4 of 9 (permalink) Old 06-16-2009, 07:25 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Backfiring thru the carb is a valve adjustment or timing issue.

Todd



Hunterworks is offline  
post #5 of 9 (permalink) Old 06-16-2009, 08:03 PM
 
Join Date: Jun 2009
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I also had the same problem last night after doing the same mods. Front carb also. Wha tI found is when I put it back together I didn't have the front carb fully seated and pushed down so I assume it was sucking air. Loosened clamps slid it down and no more problem
boilermaker is offline  
post #6 of 9 (permalink) Old 06-17-2009, 06:11 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by boilermaker View Post
I also had the same problem last night after doing the same mods. Front carb also. Wha tI found is when I put it back together I didn't have the front carb fully seated and pushed down so I assume it was sucking air. Loosened clamps slid it down and no more problem
Yeah that would do it too, didn't think about that.



Hunterworks is offline  
post #7 of 9 (permalink) Old 06-19-2009, 08:49 AM Thread Starter
Junior Member
 
Join Date: Apr 2009
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thanks for you input. It came down to the Ignition Box I installed the factory back on my Teryx and the problem went away. I just sent it back to Dynatek to be tested. I'll let ya know how it turns out.
TREX RIDER is offline  
post #8 of 9 (permalink) Old 06-20-2009, 05:21 PM
Senior Member
 
jcummins's Avatar
 
Join Date: Apr 2008
Location: Creal Springs, IL
Posts: 193
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by TREX RIDER View Post
Thanks for you input. It came down to the Ignition Box I installed the factory back on my Teryx and the problem went away. I just sent it back to Dynatek to be tested. I'll let ya know how it turns out.
They will tell you there is nothing wrong with it....but IMO...there is. They just won't owe up to their mistakes.

Todd, did you ever find another source for the coils?...to fix Dynatek's problem. I don't want to give them anymore money.
jcummins is offline  
post #9 of 9 (permalink) Old 06-21-2009, 05:17 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by jcummins View Post
They will tell you there is nothing wrong with it....but IMO...there is. They just won't owe up to their mistakes.

Todd, did you ever find another source for the coils?...to fix Dynatek's problem. I don't want to give them anymore money.
I didn't. There seems to be a compatibility issue.



Hunterworks is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
U-joint trouble? FiveFlat Kawasaki Teryx General Discussions 3 12-14-2008 04:34 PM
[Build-Up Sponsor] Double Trouble Hook dieselpowered TeryxHQ.com Announcements 0 05-06-2008 02:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89