need help pls - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx General Discussions General discussions pertaining to the Kawasaki Teryx.
Maintenance, cleaning, etc.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 08-10-2010, 02:51 PM Thread Starter
Senior Member
 
hllywood's Avatar
 
Join Date: May 2009
Posts: 112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
need help pls

I am having trouble with my teryx dying on me like when your driving and come to a stop it will die.it does it when you first start riding it or if you been riding for a while.doesn't do it every time you stop but just gets aggravating.its completely stock except wheels and tires and took
out spark arrestor.does anyone have any ideas what could be causing this.thanks any help would be appreciated.it is a 2009

Last edited by hllywood; 08-10-2010 at 03:01 PM.
hllywood is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 08-10-2010, 03:07 PM
Moderator
 
tomanytoysnotnuftime's Avatar
 
Join Date: Jun 2008
Location: Fort Saskatchewan, Alberta, Canada
Posts: 383
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
How many hours on it? Mine does the same thing, and I am sure it is because when I did my 840 kit, I think I might have the valves a bit to tight. It runs good but always stalls when I stop, but starts up and idles fine afterwards. If you have alot of hours on your machine it might be in need of a valve adjustment.

2012 VIBRANT Blue Teryx 4, Muzzy pro's, ECU reflash, custom cage & roof, windshield, 14" STI HD Beadlocks & 32x10x14 STI Roctane's/Tatou 4S Tracks, Rigid Lights, Custom bumpers, Warn XT4000 winches front & rear, bedlift

2010 black, FST 840 stage II cams, DASA intake & injectors, BF throttle bodies, Msd, Muzzy Pro`s, Snorkeled, Warn XT 4000, EMP, 2 seat race cage, Custom rear Radiator, Unisteer, STI HD beadlocks and 30x10x14 EFX motoclaws
tomanytoysnotnuftime is offline  
post #3 of 13 (permalink) Old 08-10-2010, 03:14 PM Thread Starter
Senior Member
 
hllywood's Avatar
 
Join Date: May 2009
Posts: 112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
it has 79 hours on it.i mean if you get on it or just driving runs good ,starts good. just having this issue when you have to stop or hit the brakes fast. its aggravating
hllywood is offline  
 
post #4 of 13 (permalink) Old 08-10-2010, 03:37 PM
Senior Member
 
glockman55's Avatar
 
Join Date: Dec 2009
Location: Mich
Posts: 148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
 
Idle too low?
glockman55 is offline  
post #5 of 13 (permalink) Old 08-10-2010, 04:32 PM Thread Starter
Senior Member
 
hllywood's Avatar
 
Join Date: May 2009
Posts: 112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
idle seems good is it controlled by ecu
hllywood is offline  
post #6 of 13 (permalink) Old 08-10-2010, 05:17 PM
Senior Member
 
4x4pac's Avatar
 
Join Date: Nov 2008
Location: Southern Illinois
Posts: 174
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Valves are to tight


2009 Teryx LE FI
REAL OFF ROAD RIDERS DON'T RIDE WITH FLEAS
4x4pac is offline  
post #7 of 13 (permalink) Old 08-10-2010, 09:11 PM Thread Starter
Senior Member
 
hllywood's Avatar
 
Join Date: May 2009
Posts: 112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
is that the only thing it could be runs great except for this
hllywood is offline  
post #8 of 13 (permalink) Old 08-10-2010, 09:51 PM
Member
 
Join Date: Apr 2010
Location: Edmonton Canada
Posts: 82
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by hllywood View Post
is that the only thing it could be runs great except for this
i was having a similar problem and it was cause i sunk the teryx in water and got my coils wet did that for a full day run great just wood die if you stopped or braked hard or slowed down fast. I took both coils of and blow dried them for a while to get them nice and dry. Seemed to work stopped happening after that.

P.S. i left it park for a week to and the problem just went away.
Tysonh is offline  
post #9 of 13 (permalink) Old 08-10-2010, 09:54 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Idle is controlled by three things.

Crank position sensor, ECU and Idle speed control valve.

CPS tells ECU how fast it is going and then the ECU tell the ISC valve how much to open.

The throttle plates are closed during idle, idle air goes from the air box thru ISC valve then in a passage under the throttle plate.

Your issue may be your ISC control valve might be just dirty, you can take it apart and clean it, might need a new one.

There is a idle speed on the throttle but we only mess with it when we do engine kits.

Todd



Hunterworks is offline  
post #10 of 13 (permalink) Old 08-10-2010, 09:56 PM Thread Starter
Senior Member
 
hllywood's Avatar
 
Join Date: May 2009
Posts: 112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
mine has been doing it for a while i really haven't had it in deep water or mud.i appreciate the suggestions
hllywood is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88