First issue with my 2010! FI crap... - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx General Discussions General discussions pertaining to the Kawasaki Teryx.
Maintenance, cleaning, etc.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 08-28-2011, 07:32 AM Thread Starter
Senior Member
 
Join Date: May 2010
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
First issue with my 2010! FI crap...

Ok here is the deal...was driving late at night...decided to take a powerline because it was shorter..haven't been on it in a few years..made it a few feet I think then I sunk to the right (pics to follow).

Left the bike there over night, came back with a few quads the next day and got it out. It was almost laying on the right side. When I got it out it and upright smoke started rolling out of the exhaust, which I figured would happen...that stopped after a while.

Earlier in the day I noticed my fan wasn't coming on, turns out one of the plugs that goes into that relay..probably for the temp or whatever had broke off, I could turn the fan on by holding the plug to the relay.

Driving it to the camp after getting it out the temp light was on, I stopped cooled it down....continued, I figured it would come back on, it was hot and we just worked to get it out.....the temp light went off riding back and then the FI light started blinking...I stopped checked things out, everything seems fine.

Almost back to the camp, the FI light is still going, then the belt light blinks and the Teryx quits. I wait a minute, start up, go again, same thing.

Tow it back to the camp (shame). Add a bit of oil to it, coolent resevoir is a bit low but should be fine. Start it up around 30 mins later drive it for 10 minutes, the FI light doesn't come on, Temp light does. I left it there and drove my father in laws Honda 420 home just to be safe (shame).

The battery/computer area does have some mud in there, most is dry now but I'm going to clean that all up and fix the fan relay/switch. I'm going to clean the air filter although I just did, there didn't seem to be an oil in it.

Is there anything else I can try?

Is there an O2 sensor that could be dirty maybe? Odd that it ran for 15km fine, then the FI light started coming on.

Here are some pics...any advise will help!

[IMG][/IMG]

[IMG][/IMG]

[IMG][/IMG]

shanny55 is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 08-28-2011, 09:25 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thru all that what is the present question?



Hunterworks is offline  
post #3 of 23 (permalink) Old 08-28-2011, 09:48 AM Thread Starter
Senior Member
 
Join Date: May 2010
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Well I am going to assume the FI light will come on again and it will probably quit again....I am wondering if anyone has had the same thing happen or know what i can check..or why it came on to begin with.
shanny55 is offline  
 
post #4 of 23 (permalink) Old 08-28-2011, 10:51 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by shanny55 View Post
Well I am going to assume the FI light will come on again and it will probably quit again....I am wondering if anyone has had the same thing happen or know what i can check..or why it came on to begin with.
The FI light is coming on because something is wrong in FI, most likely a loose connector some where. Usually it is not something bad or complicated.

I am at home and can't tell you how to do the diagnostic function but you can check it and it will give you a code.

If you don't have a service manual, go to tradebit.com and download one if you have a paypal account for less than $10 then go to the efi section.



Hunterworks is offline  
post #5 of 23 (permalink) Old 08-28-2011, 12:44 PM Thread Starter
Senior Member
 
Join Date: May 2010
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Yeah I did buy the service manual...I guess we'll bring it home go thru everything and see if it still acts up...
shanny55 is offline  
post #6 of 23 (permalink) Old 08-31-2011, 07:53 AM
Senior Member
 
chad59's Avatar
 
Join Date: Dec 2008
Location: Yuma, AZ
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I have an 09 manual I can email you for free. email [email protected] referance manual. Chad.
chad59 is offline  
post #7 of 23 (permalink) Old 08-31-2011, 08:05 AM Thread Starter
Senior Member
 
Join Date: May 2010
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
No I bought the 2010 manual from a forum member a while back thanks for the offer though!
shanny55 is offline  
post #8 of 23 (permalink) Old 09-01-2011, 08:23 PM
Member
 
Join Date: Jun 2010
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Hunter: I went to that web site to download and I did not see one for the 2010 model. How can I get this year manual?
livy is offline  
post #9 of 23 (permalink) Old 09-02-2011, 04:59 AM Thread Starter
Senior Member
 
Join Date: May 2010
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I got mine off of this forum or the other Teryx forum...guy sells the PDF.
shanny55 is offline  
post #10 of 23 (permalink) Old 09-02-2011, 05:02 AM Thread Starter
Senior Member
 
Join Date: May 2010
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Update:

Ok so originally I didn't think I had oil in my air box...but after inspecting a bit more I definately did. I think after we got it unstuck (rad breaker broke), the fan wouldn't come on, I drove it for 10kms with the Temp light blinking..then the FI light came on...and after a while it quit...I'm thinking running it with it hot like that may have puked up the oil into the airbox.

I'm waiting for the 12v Rad Breaker from Kawi...it's on back order so a few people must have the same issue. After I get that I'm going to see what I can. I don't think I need a "STOP" kit or whatever, this is the first time it's happened and I think it only did because the fan wasn't working and it overheated big time. I'm going to check the forums to see what you guys have done when getting oil in the airbox..if anything...hopefully I will just have to clean it and run it a bit until it burns off?
shanny55 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HID connectivity issue sleepy23 Kawasaki Teryx Electrical Discussions 6 09-24-2010 08:38 AM
brake issue???????? badlime09teryx Member Introductions 5 07-22-2010 08:17 PM
2010 King of the Hammers UTV Race - Feb 11, 2010 Crowdog UTV Desert Racing 0 12-17-2009 11:16 AM
Got a new issue, uaqsports Kawasaki Teryx Performance Discussions 8 11-09-2009 11:17 AM
4x4 issue maybe? Mayo304 Kawasaki Teryx General Discussions 3 11-02-2009 07:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89