Need help with cold starting problem with FI Teryx - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx General Discussions General discussions pertaining to the Kawasaki Teryx.
Maintenance, cleaning, etc.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 03-17-2012, 08:21 PM Thread Starter
Member
 
Join Date: Apr 2010
Location: Florida
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Need help with cold starting problem with FI Teryx

My 2010 with fuel injection has been giving me problems with strarting when cold. If I don't give it the gas it will only crank over and not catch. If I give it some gas it will start, but stop as soon a I release the gas pedal. I don't get the same problem when the engine is hot. Is there a solenoid or sensor that engages the choke for cold start? I just changed the spark plugs hoping that would help, but it starts the same.
Any suggestions?
Rocky is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 03-18-2012, 11:04 PM
Moderator
 
tomanytoysnotnuftime's Avatar
 
Join Date: Jun 2008
Location: Fort Saskatchewan, Alberta, Canada
Posts: 383
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Sounds like its time for a valve adjustment maybe?? How many miles??

2012 VIBRANT Blue Teryx 4, Muzzy pro's, ECU reflash, custom cage & roof, windshield, 14" STI HD Beadlocks & 32x10x14 STI Roctane's/Tatou 4S Tracks, Rigid Lights, Custom bumpers, Warn XT4000 winches front & rear, bedlift

2010 black, FST 840 stage II cams, DASA intake & injectors, BF throttle bodies, Msd, Muzzy Pro`s, Snorkeled, Warn XT 4000, EMP, 2 seat race cage, Custom rear Radiator, Unisteer, STI HD beadlocks and 30x10x14 EFX motoclaws
tomanytoysnotnuftime is offline  
post #3 of 14 (permalink) Old 03-19-2012, 06:44 AM Thread Starter
Member
 
Join Date: Apr 2010
Location: Florida
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I've got 1200 miles on it.
Rocky is offline  
 
post #4 of 14 (permalink) Old 03-19-2012, 08:16 PM
Member
 
SouthCo's Avatar
 
Join Date: Dec 2010
Location: Maryland
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Yeah I'd probably start with a valve adjustment.

2010 Teryx
SouthCo is offline  
post #5 of 14 (permalink) Old 03-19-2012, 08:42 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Bad news is that if a valve adjustment fixes it or they are very tight you will know that your valves are deforming and "sucking up" in the heads

Also if this is the case get mentally and financially prepared to install some good aftermarket valves and springs.



Hunterworks is offline  
post #6 of 14 (permalink) Old 03-25-2012, 06:30 AM
Senior Member
 
Join Date: Jan 2009
Location: MAGNOLIA,TEXAS
Posts: 526
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Mine did same thing. Adjusted the valves and much better.

09 teryx- msd ignition - water impellar - half windsheild - uni filter - standard muzzy - sdr rear bumper - hid lights - dalton clutch- water temp guage - ss108 14 inch with terra cross - dasa kebc block off plate - brake alarm buzzer - over drive plate -ssv works sound system -removable canvas top-odyssey battery- rock sliders
codyo is offline  
post #7 of 14 (permalink) Old 03-25-2012, 08:14 AM Thread Starter
Member
 
Join Date: Apr 2010
Location: Florida
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thanks everyone, ended up taking it to the dealer. The hooked it up to the computer and found all sensors were OK. They have been back logged with work and haven't gone any further. I will talk to them on Monday about a valve adjustment. Todd I hope you are not right this time. Just out of curiosity what would it run for new valves and springs?
Rocky is offline  
post #8 of 14 (permalink) Old 03-25-2012, 09:41 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Rocky View Post
Thanks everyone, ended up taking it to the dealer. The hooked it up to the computer and found all sensors were OK. They have been back logged with work and haven't gone any further. I will talk to them on Monday about a valve adjustment. Todd I hope you are not right this time. Just out of curiosity what would it run for new valves and springs?
Depends, you dealer is not gonna have a clue what actually needs to be done. If you ask them they would want to put back stock valves and springs. They probably don't know the reason people have to keep adjusting valves is the valve face is wearing.

Springs are $125 and valves are $288, installation ?????? Here probably $600 labor but you gonna get new rings too.

The only time this is a known issue is when it starts hard, adjusting the valves fixes it and then it does it again pretty soon.

Todd



Hunterworks is offline  
post #9 of 14 (permalink) Old 03-26-2012, 08:24 AM Thread Starter
Member
 
Join Date: Apr 2010
Location: Florida
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thanks Todd, I'll let you know if I need to make a trip to your shop, you're about 800 miles away. Do you make house calls? By the way the UNI filter worked great, the air plenun was pretty clean when I pulled it off.
Rocky is offline  
post #10 of 14 (permalink) Old 03-26-2012, 08:31 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Rocky View Post
Thanks Todd, I'll let you know if I need to make a trip to your shop, you're about 800 miles away. Do you make house calls? By the way the UNI filter worked great, the air plenun was pretty clean when I pulled it off.
No house calls unless you have a hot single sister in law!!

We will let you ship it in though



Hunterworks is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Teryx not starting in the cold? $kidoo Kawasaki Teryx General Discussions 39 01-16-2011 06:47 PM
2009 teryx will not idle when cold robowelder Kawasaki Teryx General Discussions 10 09-11-2010 09:34 PM
08 Hard Starting Problem jtgroover Kawasaki Teryx General Discussions 9 04-05-2010 10:32 AM
Dying teryx problem!!! bradenbaugh Kawasaki Teryx General Discussions 16 08-09-2008 09:20 AM
Cold Weather Starting buckshot Kawasaki Teryx General Discussions 3 04-23-2008 02:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88