fuel problems? - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx General Discussions General discussions pertaining to the Kawasaki Teryx.
Maintenance, cleaning, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-22-2012, 09:38 AM Thread Starter
Junior Member
 
Join Date: Apr 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
fuel problems?

i need some help on an issue i have... i started out having a clogged up fuel pump i took it apart replaced the strainer on the bottom of the pump and cleaned the pump and all the parts.. i put it all back together and tested the volume i am gettin 1.7 ounces every time i turn the key on as the shop manual says i should but i dont have any way to test the pressure... i hook it back to the throttle bodies and get very inconsitant spray from the injectors i took them all apart and cleaned the injectors and reassembled the spray looked strong to me but still inconsitant will not start on its own if i give it a shot of ether it will start and die as soon as it burns the ether up and wont run on its own fuel i am stumped i dont know where to go from here im not getting a fi light
taderhead is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-22-2012, 09:53 AM
TeryxHQ.com Staff Member
 
DougS's Avatar
 
Join Date: Apr 2008
Location: Alberta, Canada
Posts: 2,107
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Did crud get down the line past the fuel pump?
DougS is offline  
post #3 of 6 (permalink) Old 04-22-2012, 12:07 PM Thread Starter
Junior Member
 
Join Date: Apr 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
im not really sure i cleaned the pump and all parts of the pump unit and cleaned the injectors and the fuel rails
taderhead is offline  
 
post #4 of 6 (permalink) Old 04-25-2012, 08:34 PM
Junior Member
 
Join Date: Jan 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
09 fuel pump

Quote:
Originally Posted by taderhead View Post
im not really sure i cleaned the pump and all parts of the pump unit and cleaned the injectors and the fuel rails
mine did the same thing added a o ring to fuel pump connector where they snapped together 559 707 4420
haydaddy is offline  
post #5 of 6 (permalink) Old 07-30-2012, 10:09 AM
Junior Member
 
Join Date: Jul 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I have a 2008 Teryx and am having the same problem the fuel filter is new the carbs were just re jeted by a kawi dealer and the shop man tells me the fuel pumps are known to crap out. I ordered a new one to see if that solves the problem. Seems like the fuel just trickles into the filter a drop at the time and the filter never gets more than 1/4 full.
freytes2004 is offline  
post #6 of 6 (permalink) Old 07-31-2012, 08:16 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by taderhead View Post
i need some help on an issue i have... i started out having a clogged up fuel pump i took it apart replaced the strainer on the bottom of the pump and cleaned the pump and all the parts.. i put it all back together and tested the volume i am gettin 1.7 ounces every time i turn the key on as the shop manual says i should but i dont have any way to test the pressure... i hook it back to the throttle bodies and get very inconsitant spray from the injectors i took them all apart and cleaned the injectors and reassembled the spray looked strong to me but still inconsitant will not start on its own if i give it a shot of ether it will start and die as soon as it burns the ether up and wont run on its own fuel i am stumped i dont know where to go from here im not getting a fi light
You can either get a fuel pressure gauge or trouble shoot with a $500 pump. The question is, is it holding pressure under load?



Hunterworks is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with fan. atv4fun Kawasaki Teryx Electrical Discussions 6 07-19-2010 12:01 AM
Any problems with the unifilters? jaketruck Kawasaki Teryx Performance Discussions 8 06-08-2010 02:55 PM
Flooding problems! Please help my 08!! Hnryzuniga Kawasaki Teryx General Discussions 14 05-13-2010 01:29 PM
Dynojet problems?? Fletch-c Kawasaki Teryx Performance Discussions 35 05-25-2009 02:12 PM
New and already have problems Lhall Member Introductions 7 08-25-2008 08:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89