overheating - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx General Discussions General discussions pertaining to the Kawasaki Teryx.
Maintenance, cleaning, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-17-2008, 03:18 PM Thread Starter
Junior Member
 
BeerGuzzler's Avatar
 
Join Date: Mar 2008
Location: Acton,Ca.
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
overheating

Double check and make sure your wires going to the pressure switch on the radiator are connected,mine where not which made for a weekend of overheating!(hopefully that was the problem I did not find the hanging wires till I got home)other than that the Mighty Teryx is a climbing animal! or is that dinasour? ha
BeerGuzzler is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-17-2008, 03:36 PM
CommanderTalk.com
 
dieselpowered's Avatar
 
Join Date: Feb 2008
Location: Peoria, AZ
Posts: 2,799
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Ya I was kinda thinking that my motor runs hotter than in should as the fan was always kicking on. I understand that it is set to kick in at 157-162 degrees, however, it just kinda seemed to come on quite a bit.

What was happening to yours? Meaning, what was making you think the motor was overheating? Spitting coolant?




AllTerrainJournal.com --> www.AllTerrainJournal.com

I support every man and women in the armed forces, I wish you all the best and thank you!

2008 Kawasaki Teryx | 840cc BBK w/ stage III cams | FST long travel and HD steering | Twisted Stitch seats | FST cage | Muzzy dual exhaust | Dynatek prog CDI | aFe intake | HiPer carbon fiber beadlocks | Goodyear MT/Rs | Crow restraints | SafeGlo LED and FO whips | NightOwl HID conversion | Edge series 40" LED lightbar | Fuego Dual HID lights | Dalton clutch kit and OD cover | Full audio | Navigation | Power steering | TrailTech Vapor computer | Factory UTV skids | Airtite Art custom paint | Maier plastics
dieselpowered is offline  
post #3 of 6 (permalink) Old 03-18-2008, 03:26 PM Thread Starter
Junior Member
 
BeerGuzzler's Avatar
 
Join Date: Mar 2008
Location: Acton,Ca.
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
My red temp light on the dash came on and the coolant was bubbling in the overflow tank down on the floorboard.I hope the wires being disconnected was the problem I never heard the fan kick on.I'll find out if that was the problem this weekend we are headed back out to the dez!
BeerGuzzler is offline  
 
post #4 of 6 (permalink) Old 03-18-2008, 03:33 PM
CommanderTalk.com
 
dieselpowered's Avatar
 
Join Date: Feb 2008
Location: Peoria, AZ
Posts: 2,799
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Ya luckily I have never had those indicator lights going on.

Check to see that your fan is going on...if it is not, that could indicate there is another issue

On a different note, have a great ride...I am hoping to get out as well this weekend.




AllTerrainJournal.com --> www.AllTerrainJournal.com

I support every man and women in the armed forces, I wish you all the best and thank you!

2008 Kawasaki Teryx | 840cc BBK w/ stage III cams | FST long travel and HD steering | Twisted Stitch seats | FST cage | Muzzy dual exhaust | Dynatek prog CDI | aFe intake | HiPer carbon fiber beadlocks | Goodyear MT/Rs | Crow restraints | SafeGlo LED and FO whips | NightOwl HID conversion | Edge series 40" LED lightbar | Fuego Dual HID lights | Dalton clutch kit and OD cover | Full audio | Navigation | Power steering | TrailTech Vapor computer | Factory UTV skids | Airtite Art custom paint | Maier plastics
dieselpowered is offline  
post #5 of 6 (permalink) Old 03-18-2008, 08:45 PM
Senior Member
 
mouser58's Avatar
 
Join Date: Mar 2008
Location: New Martinsville, W.Va.
Posts: 180
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Send a message via AIM to mouser58
My V-Force and Brute force both seemd to run all of the time when Woods riding, but never noticed it on open roads. But every time I shut them off, they always kicked on.
mouser58 is offline  
post #6 of 6 (permalink) Old 03-18-2008, 08:48 PM
CommanderTalk.com
 
dieselpowered's Avatar
 
Join Date: Feb 2008
Location: Peoria, AZ
Posts: 2,799
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by mouser58 View Post
My V-Force and Brute force both seemd to run all of the time when Woods riding, but never noticed it on open roads. But every time I shut them off, they always kicked on.
Thats exactly where I am at. Open runs, no worries...slower speeds through the desert, fan comes on.




AllTerrainJournal.com --> www.AllTerrainJournal.com

I support every man and women in the armed forces, I wish you all the best and thank you!

2008 Kawasaki Teryx | 840cc BBK w/ stage III cams | FST long travel and HD steering | Twisted Stitch seats | FST cage | Muzzy dual exhaust | Dynatek prog CDI | aFe intake | HiPer carbon fiber beadlocks | Goodyear MT/Rs | Crow restraints | SafeGlo LED and FO whips | NightOwl HID conversion | Edge series 40" LED lightbar | Fuego Dual HID lights | Dalton clutch kit and OD cover | Full audio | Navigation | Power steering | TrailTech Vapor computer | Factory UTV skids | Airtite Art custom paint | Maier plastics
dieselpowered is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89