09 Belt Warning Light Flashing, Loss of Power, Etc. - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx General Discussions General discussions pertaining to the Kawasaki Teryx.
Maintenance, cleaning, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-19-2013, 12:22 PM Thread Starter
Junior Member
 
Join Date: Sep 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
09 Belt Warning Light Flashing, Loss of Power, Etc.

Gentlemen - I have a 2009 with fuel injection. On a recent trip to Moab, we were driving down a relatively flat two-track road at 15 - 20 mph. Temperature was approximately 70 F. The belt warning light began to flash rapidly, the motor lost power, the speedometer began showing 0, and the coolant temp icon came on. I pulled over and shut down the motor. I put the ignition in "on" so that the fan would run. After 5 - 10 minutes, I started back up. After driving for 2 - 5 minutes, the same process repeated itself. We eventually were able to limp back to the truck. I called my dealer who suspected a problem with the speed sensor. The speed sensor connection is solid.

Upon returning home, I drove it to the dealership without problem. The dealer and I took it for a test drive and were unable to replicate the issue. Thoughts? Ideas? Suggestions? Thanks very much. ELN
Wyoming Shooter is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-30-2013, 11:51 AM
Junior Member
 
Join Date: Nov 2012
Location: northern Utah
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I would check all of the electrical connections, I know that they are voltage sensitive, on the prairie a low battery would make the light come on. the speedo reading zero would make me thing a electrical connection or a speed sensor. I know the teryx belt protection monitors wheel speed and if the throttle is applied but the speedo reads zero for to long the computer will cut power to prevent damage. a speedo reading zero would cause this. If the speed sensor is good I would start with battery cables and fuses and then grounds to make sure everything is tight. on my prairie a loose battery cable would foul up the system.
wizard of oz is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Teryx, FI light flashing krazykoser Kawasaki Teryx Performance Discussions 4 09-12-2015 06:48 PM
Power Loss when warm AfghanTeryx Kawasaki Teryx Performance Discussions 10 08-05-2011 01:03 AM
help loss of power kaptn12 Kawasaki Teryx Performance Discussions 15 05-19-2011 10:41 PM
2009 stock Teryx: 100 miles, FI and Belt Light Flashing mperdue63 Kawasaki Teryx General Discussions 13 03-21-2010 08:08 AM
08 Teryx LE power loss jeryx Kawasaki Teryx General Discussions 0 11-15-2009 03:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89