08 feels sluggish - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Performance Discussions Kawasaki Teryx performance discussions.
Engine mods, CDI boxes, exhausts, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-10-2013, 09:18 AM Thread Starter
Junior Member
 
Join Date: Jun 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
08 feels sluggish

I recently purchased a 2008 teryx used. It feels like it is taking longer to pick up speed and struggles to reach 48 to 49 miles per hour. It also has a occasional miss when at idle and when running low rpms. It pops through the exhast on decceleration. The belt makes a noise like it slips on hard acceleration but only for a second. The bike is stock accept for 26X11X12 tires on itp wheels. I have adjusted the valves the carb seems to be clean the only thing i havent done is change the fuel filter. I have two different cdi boxes a dynatek and pro con but neither one makes a lot of difference max speed is around 52 with them. I am open for any ideas as to what it may be.
radrider86 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-10-2013, 10:29 PM
TeryxHQ.com Staff Member
 
DougS's Avatar
 
Join Date: Apr 2008
Location: Alberta, Canada
Posts: 2,107
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Belt loose or glazed?
Exhaust partially plugged with mud?
Jetting may be off a bit but never had to much issue with deceleration pop if iits minor.
DougS is offline  
post #3 of 4 (permalink) Old 07-14-2013, 09:08 PM
Junior Member
 
Michigan treyx's Avatar
 
Join Date: Apr 2013
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by radrider86 View Post
I recently purchased a 2008 teryx used. It feels like it is taking longer to pick up speed and struggles to reach 48 to 49 miles per hour. It also has a occasional miss when at idle and when running low rpms. It pops through the exhast on decceleration. The belt makes a noise like it slips on hard acceleration but only for a second. The bike is stock accept for 26X11X12 tires on itp wheels. I have adjusted the valves the carb seems to be clean the only thing i havent done is change the fuel filter. I have two different cdi boxes a dynatek and pro con but neither one makes a lot of difference max speed is around 52 with them. I am open for any ideas as to what it may be.
How many miles? I would say check the belt deflection or replace the belt.

2012 Teryx4 EPS
4500lb Super Winch
Half shield
Kawi Cargo Box
Kawi Soft Top
Michigan treyx is offline  
 
post #4 of 4 (permalink) Old 07-25-2013, 06:14 PM Thread Starter
Junior Member
 
Join Date: Jun 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Well I got it fixed turned out I needed intake valves I also replaced the belt while I was working on it. It runs great now. Thanks for all the help.
radrider86 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Teryx HQ feels like home!!! Hunterworks TeryxHQ Help Desk 10 10-12-2008 03:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68