Need help with carbs - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Performance Discussions Kawasaki Teryx performance discussions.
Engine mods, CDI boxes, exhausts, etc.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 10-19-2008, 09:40 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: Ontario, Califas
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Need help with carbs

On first test run after I completed installing evertyhing, I have bad sputter/popping when accelarating from 20-30mph. I am at half throttle then I step on it and get the sputtering/popping.

During this run, I forgot to hook up the crankase hose to the plenum/elbow and took off the rubber piece from the top of the airbox lid.

On my second run, I put the rubber piece back on and connected the crankase hose. It sputtered/popped right away. On my first run, I was able to reach a steady cruising speed and would only get the sputtering/popping after I stepped on the pedal.

Am I not getting enough air, vacum to the slides, or do I need bigger jets?

What I did;

I installed my ACracing dual exhaust and Velocity air filter.

I switched the bent connector between the air box and carb plenum/elbow to a straight connector I picked up at Pep Boys. No airbox mods.

My dynojet kit came with leftover jets from the dragonfire kit. Vendor at the sandsports who sold me the exhaust also has AC racing duals with 190 front and 195 rear jets. He is running the AFE intake, I just have the Velocity filter but I did change the elbow.

I have Dynojet 180 front and 185 rear. Clip is on second groove with two spacers on top. Slide springs and needles are same on both kits. Front and rear mixture screw is out two turns.

From factory, the fuel mixture screw was out 1 1/2 turns on the front and 1 turn out on the rear.
I can turn the
front mixture another 1/2 turn to match the rear by adding a complete turn to both carbs.
I already had an adjustable dynatek cdi from Hunterworks.

Thank you for your help, I am heading to Glamis on Thursday.

Last edited by red hippo; 10-19-2008 at 10:09 PM.
red hippo is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 10-20-2008, 05:30 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
In my opinion it is your air intake, put the stock one back on and one size larger jets back in. Also be ready for back firing on decel with that exhaust until you put some larger pilot jets in.



Hunterworks is offline  
post #3 of 14 (permalink) Old 10-20-2008, 11:31 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: Ontario, Califas
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I took the lid off!
red hippo is offline  
 
post #4 of 14 (permalink) Old 10-21-2008, 05:54 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Took the lid off??

I'm confused, if you put the stock intake back on then put the lid on it too.



Hunterworks is offline  
post #5 of 14 (permalink) Old 10-21-2008, 01:12 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: Ontario, Califas
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Todd, all I did was take the lid off and it fixed my sputtering problem. I still need to finish tuning the carbs, but I am in the ballpark.

Thanks for your help.

Last edited by red hippo; 10-22-2008 at 01:00 AM.
red hippo is offline  
post #6 of 14 (permalink) Old 10-21-2008, 06:51 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Still lost on what intake you have but if it works without a lid then your lucky but I promise you won't get top performance with it off.



Hunterworks is offline  
post #7 of 14 (permalink) Old 10-21-2008, 08:11 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: Ontario, Califas
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
The only item replaced on my intake is the bent coupler/connecter that come factory. I replaced that with a straight thru connector/coupler. It moved the airbox over towards the driver but it will work for Glamis.

Withe the lid on, it idled fine and reved up no problem but was horrible when I took it down my street. Correction, I just turned into my driveway. There was no point to conitnue, it sputtered and popped.

I take the lid off, and it runs strong.

I have read just about all posts and threads regarding this right after I bought my Teryx. I thought I couldn't run without a lid.
red hippo is offline  
post #8 of 14 (permalink) Old 10-21-2008, 09:51 PM
CommanderTalk.com
 
dieselpowered's Avatar
 
Join Date: Feb 2008
Location: Peoria, AZ
Posts: 2,799
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Sounds to me like you are rich.

When the lid is on (less air) you do not run correctly, when the lid is off (more air) you run correctly. Tells me you are rich, however, without an air fuel meter one cannot be sure.




AllTerrainJournal.com --> www.AllTerrainJournal.com

I support every man and women in the armed forces, I wish you all the best and thank you!

2008 Kawasaki Teryx | 840cc BBK w/ stage III cams | FST long travel and HD steering | Twisted Stitch seats | FST cage | Muzzy dual exhaust | Dynatek prog CDI | aFe intake | HiPer carbon fiber beadlocks | Goodyear MT/Rs | Crow restraints | SafeGlo LED and FO whips | NightOwl HID conversion | Edge series 40" LED lightbar | Fuego Dual HID lights | Dalton clutch kit and OD cover | Full audio | Navigation | Power steering | TrailTech Vapor computer | Factory UTV skids | Airtite Art custom paint | Maier plastics
dieselpowered is offline  
post #9 of 14 (permalink) Old 10-22-2008, 01:00 AM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: Ontario, Califas
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
correction... I do have the velocity filter kit.
red hippo is offline  
post #10 of 14 (permalink) Old 10-22-2008, 07:50 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Hard to say, some combinations may work ok. I'm still of the belief the stock box with our mod works the best. A 6hp gain is hard to beat!!



Hunterworks is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
carbs teryx/brute force bradenbaugh Kawasaki Teryx Performance Discussions 6 08-10-2008 11:37 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88