2009 teryx bogs only when warm? - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Performance Discussions Kawasaki Teryx performance discussions.
Engine mods, CDI boxes, exhausts, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-26-2014, 03:07 PM Thread Starter
Junior Member
 
Join Date: May 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Question 2009 teryx bogs only when warm?

New guy here thought I might get some info on this problem. My teryx is bogging after it warms up there are no codes. stranger yet is if I get it wet it runs like a top no miss no sputter and all kinds of power. coolant is all good cooling fan works fine. I did notice that my air idle control was hot but never got water up that high. in other words it runs great in the river. slow and bogs wile out of water still have full speed just very slow getting there. new engine as well.

Last edited by Bender101; 05-27-2014 at 02:02 PM. Reason: left out some info
Bender101 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-28-2014, 04:32 PM Thread Starter
Junior Member
 
Join Date: May 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Ok had fuel pump checked was 28psi. Looked into specs for the 750 fi. Found that I need 43psi so I found the 1988 dodge Omni fuel pump it has a pressure of 47psi as seen on utube. Doing the mod simply for the inexpensive fuel pump and future replacement. what I figure so far is that riding in the cold river somehow sets the system into a cold start mode or something to that effect witch I think the injectors must adjust or open further for more fuel without having to adjust the butterflies. for example larger fuel injectors lower fuel pressure. giving it the right amount of fuel at a lower pressure. Does that sound about right?
Bender101 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Loss when warm AfghanTeryx Kawasaki Teryx Performance Discussions 10 08-05-2011 01:03 AM
2009 Teryx zackattacker192 Member Introductions 12 07-29-2009 08:31 PM
2009 Teryx! GSharp Member Introductions 1 12-02-2008 01:22 PM
2009 Teryx gets EFI! New Teryx Sport announced! Thunderhawk Kawasaki Teryx General Discussions 22 09-24-2008 11:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89