Dynojet problems?? - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Performance Discussions Kawasaki Teryx performance discussions.
Engine mods, CDI boxes, exhausts, etc.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 36 (permalink) Old 04-05-2009, 04:40 PM Thread Starter
Member
 
Fletch-c's Avatar
 
Join Date: Jun 2008
Location: Chardon, Ohio
Posts: 61
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Dynojet problems??

I just installed the Dynojet jet kit in my Teryx. Out of the hole it is awsome. However at about 47-50 I am missing? and it is faling on its face. Do I need to lean it out a little? I have the mixture screws set at 3 turns out (just as the instructions said). I want to turn them in but I don't want to get them to lean. I have a LAC dual exhaust. Dynotec CDI. do I need more air? Help please.
Fletch-c is offline  
Sponsored Links
Advertisement
 
post #2 of 36 (permalink) Old 04-05-2009, 05:46 PM
Build Sponsor
 
SandJunkie's Avatar
 
Join Date: Apr 2008
Location: Bumfuque, CA
Posts: 796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
At that speed your well into the top end...that means it's too lean up top. What size jets are you running?...If you have the Stage 1 kit then bump up both the front and rear 1 size and then see what it's doing.
SandJunkie is offline  
post #3 of 36 (permalink) Old 04-05-2009, 05:52 PM Thread Starter
Member
 
Fletch-c's Avatar
 
Join Date: Jun 2008
Location: Chardon, Ohio
Posts: 61
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
134 in the front and 138 in the rear. No stage one kit the motor is stock.
Fletch-c is offline  
 
post #4 of 36 (permalink) Old 04-05-2009, 08:15 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Sounds like you need larger mains, I set our kit up with 144 and 146 with the Muzzy

Of course we have two TPI valves with the jet kit too.

Todd



Hunterworks is offline  
post #5 of 36 (permalink) Old 04-05-2009, 08:49 PM
Build Sponsor
 
SandJunkie's Avatar
 
Join Date: Apr 2008
Location: Bumfuque, CA
Posts: 796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Fletch-c View Post
134 in the front and 138 in the rear. No stage one kit the motor is stock.
At least 138 front and 142 rear...might even try Todd's suggestion...
SandJunkie is offline  
post #6 of 36 (permalink) Old 04-05-2009, 08:54 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
What clip position?



Hunterworks is offline  
post #7 of 36 (permalink) Old 04-05-2009, 10:35 PM
Build Sponsor
 
SandJunkie's Avatar
 
Join Date: Apr 2008
Location: Bumfuque, CA
Posts: 796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
If your using the DynoJet kit? I say second clip like they suggest for below 5000 feet...

If your doing it youself with no DJ kit?...Then shim the stock needle 20 thousandths and cut the stock springs 5 rungs down...
SandJunkie is offline  
post #8 of 36 (permalink) Old 04-06-2009, 05:06 AM Thread Starter
Member
 
Fletch-c's Avatar
 
Join Date: Jun 2008
Location: Chardon, Ohio
Posts: 61
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by SandJunkie View Post
If your using the DynoJet kit? I say second clip like they suggest for below 5000 feet...

If your doing it youself with no DJ kit?...Then shim the stock needle 20 thousandths and cut the stock springs 5 rungs down...
I am using the Dynojet Q221.001 kit. It recomends the134 and 138. The stock jets I took out are 135 and 140. The clip is on the 2nd ring. I will rejet tonight. We are going to get some snow today so I don't know if that will be a good test in that cold air, when yesterday it was in the mid 60's when I tested it. Heck I will run it anyway. Thanks for the info and Ill let you know.
PS I am tired of this weather in NE Ohio.
Thanks SandJunkie

Last edited by Fletch-c; 04-06-2009 at 05:14 AM.
Fletch-c is offline  
post #9 of 36 (permalink) Old 04-06-2009, 05:09 AM Thread Starter
Member
 
Fletch-c's Avatar
 
Join Date: Jun 2008
Location: Chardon, Ohio
Posts: 61
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Hunterworks View Post
Sounds like you need larger mains, I set our kit up with 144 and 146 with the Muzzy

Of course we have two TPI valves with the jet kit too.

Todd
Thanks Tod, How far open are the TPI valves? And which filter do you have in ?
Fletch-c is offline  
post #10 of 36 (permalink) Old 04-06-2009, 05:42 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Wide open and either stock filter or UNI.

Todd



Hunterworks is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
08 teryx problems please help brian Kawasaki Teryx General Discussions 18 03-29-2010 12:25 PM
Relay Problems CastleWorksTeryx Kawasaki Teryx Electrical Discussions 5 01-31-2010 11:09 AM
Teryx Dynojet Kit dbmachine Kawasaki Teryx's & Teryx Parts For Sale 1 02-26-2009 10:01 PM
New and already have problems Lhall Member Introductions 7 08-25-2008 08:39 AM
[Build-Up Sponsor] Dynojet Research dieselpowered TeryxHQ.com Announcements 0 03-26-2008 01:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88