new teryx owner - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Performance Discussions Kawasaki Teryx performance discussions.
Engine mods, CDI boxes, exhausts, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 04-15-2010, 07:26 PM Thread Starter
Junior Member
 
Join Date: Apr 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
new teryx owner

Looking for advice, please help. While riding teryx today belt light kicked on and speedometer quit working. After turning machine off and back on this happened two mote times. After third time road for about an hour with no problems. Any advice would be appreciated.
lm5181 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-15-2010, 07:34 PM Thread Starter
Junior Member
 
Join Date: Apr 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
new teryx owner

Looking for advice please help. While riding today belt light came on and speedometer quit. After turning machine off and back on this happened two more times. After third time ran for almost an hour with no problems. Any advice or suggestions would be appreciated. Thank you.
lm5181 is offline  
post #3 of 7 (permalink) Old 04-16-2010, 09:22 AM
Senior Member
 
Join Date: Aug 2009
Location: Ft. McMurray, Alberta
Posts: 235
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
What year is the machine, how many hours? milage? mods, tires?

It sound to me like your belt is out of adjustment. Are you getting any chirping from the belt? burning rubber smell??
h0tr0d18 is offline  
 
post #4 of 7 (permalink) Old 04-16-2010, 10:36 AM Thread Starter
Junior Member
 
Join Date: Apr 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
to hot rod18

Thanks for responding. It is an 09 15hours and about 150 miles. Stock no mods, no belt noise or smell.
lm5181 is offline  
post #5 of 7 (permalink) Old 04-16-2010, 12:55 PM
Senior Member
 
Join Date: Aug 2009
Location: Ft. McMurray, Alberta
Posts: 235
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I don't even know what the service interval is for sure on these things. I thik the initial is like 100 miles or something. I put mine off a little longer due to me tearing it down for cages and bumpers, pipes etc. So I am now sitting with 380kms on the meter and she's getting tore down. I have got some chirping on steep grades when in 4 wheel locked especially when teetering on 2 wheels lol. You are obviously getting something out of the normal operating parameters happening. The only time I have ever seen my belt lights, even with my chirping was when I hydrolocked my engine from the breather tube filling my engine with oil (there's a link, I think mine was the worst I have seen) once everything returned to normal the lights shut off. If I remember right these things do not store trouble codes like a vehicle but I may be wrong.

If all else fails get your stealership to check it out, it is still under warranty.
h0tr0d18 is offline  
post #6 of 7 (permalink) Old 04-19-2010, 11:07 AM
Junior Member
 
Join Date: Jul 2009
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
the service is 200 hours....however i have a 2008 and i hooked to a tree with my winch....tried to pull this tree in reverse and the belt started to roll smoke....the tree was too large for a f-350 to pull....i was drinking a little too much.....so after i unhooked tree...and ran machine it was making a clunking sound at low speeds....i used it all winter to plow snow and had no problem....this week i replaced the belt and installed a dalton cluch kit....the belt looked good but it was not quite as wide as new stock belt....and my noise went away......DON"T TRY TO PULL TREES IN REVERSE THAT YOUR TRUCK WOULDNT PULL....LOL
catalano home audio is offline  
post #7 of 7 (permalink) Old 04-19-2010, 11:46 AM
Senior Member
 
Join Date: Aug 2009
Location: Ft. McMurray, Alberta
Posts: 235
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by catalano home audio View Post
the service is 200 hours....however i have a 2008 and i hooked to a tree with my winch....tried to pull this tree in reverse and the belt started to roll smoke....the tree was too large for a f-350 to pull....i was drinking a little too much.....so after i unhooked tree...and ran machine it was making a clunking sound at low speeds....i used it all winter to plow snow and had no problem....this week i replaced the belt and installed a dalton cluch kit....the belt looked good but it was not quite as wide as new stock belt....and my noise went away......DON"T TRY TO PULL TREES IN REVERSE THAT YOUR TRUCK WOULDNT PULL....LOL
I think we should make a thread about Teryx rules lol!!!! This should be at the top of the list hahah
h0tr0d18 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Down under Teryx owner jhammers Member Introductions 9 06-08-2009 04:09 AM
New Teryx owner here. 2zuks Member Introductions 7 02-27-2009 10:04 PM
teryx owner preachersam Member Introductions 1 09-30-2008 08:30 PM
New Teryx Owner spyder1953 Member Introductions 4 09-08-2008 10:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88