Todd, or carb guys help!!! - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Performance Discussions Kawasaki Teryx performance discussions.
Engine mods, CDI boxes, exhausts, etc.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-15-2011, 06:45 PM Thread Starter
Member
 
Join Date: Nov 2008
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Todd, or carb guys help!!!

So I just got done with jetting my carbs, and took the car for a ride and it runs like crap. So here is what I have. 08 with dyna cdi and coils, dalton and overdrive plate, and muzzy pros. Jetting is as follows: 2 1/2 turns out on screws, d/j 146 150 jets, dj teryx needles with clip on 2nd notch and 2 washers, slide drilled with 1 addt'l 1/16 hole, hunterworks springs. I have an ehs racing airbox lid with the outerwear, and a stock one. I ran it with both and did not seem to make a difference. It would only top out at about 43 mph and i could hear it popping on top end. It also will ocasionally pop at idle.
I have run it stock with the cdi and coils, but this was the first run with the clutch and pipes/jetting. I can't tell if its lean or rich. Spark plug color is good. This car always ran cold blooded stock and needed choke till it warmed up. It always has popped some at idle. I found the rear carb screw fully closed when I took it apart, don't know if this was normal or not. It starts much better now, but if I hold the rpm at about 4000 in n it will be revving and pop through carbs from time to time. So the question is, WHAT DO I DO??? Thanks!
ultimate1 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-16-2011, 05:21 AM
Junior Member
 
jeffsj's Avatar
 
Join Date: Sep 2011
Location: Natural Dam, Arkansas
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Garage
Quote:
Originally Posted by ultimate1 View Post
So I just got done with jetting my carbs, and took the car for a ride and it runs like crap. So here is what I have. 08 with dyna cdi and coils, dalton and overdrive plate, and muzzy pros. Jetting is as follows: 2 1/2 turns out on screws, d/j 146 150 jets, dj teryx needles with clip on 2nd notch and 2 washers, slide drilled with 1 addt'l 1/16 hole, hunterworks springs. I have an ehs racing airbox lid with the outerwear, and a stock one. I ran it with both and did not seem to make a difference. It would only top out at about 43 mph and i could hear it popping on top end. It also will ocasionally pop at idle.
I have run it stock with the cdi and coils, but this was the first run with the clutch and pipes/jetting. I can't tell if its lean or rich. Spark plug color is good. This car always ran cold blooded stock and needed choke till it warmed up. It always has popped some at idle. I found the rear carb screw fully closed when I took it apart, don't know if this was normal or not. It starts much better now, but if I hold the rpm at about 4000 in n it will be revving and pop through carbs from time to time. So the question is, WHAT DO I DO??? Thanks!
Hey Ultimate1, It sound like it's running lean to me. The popping at wide open throttle is indicative of leanness. Does it pop when the engine is breaking? I had a simular problem with my 08 though not all the mods. It turned out to be the fuel pump was starting to get weak. The higher fuel demand might accentuate the problem. It's pretty easy to check it out. Just remove the fuel line to the carb, plug it, and use the gravity feed method(a bottle with a piece of vac hose) to keep the bowls full. Don't know if thats the problem but if it runs good for a short time and then messes up might be a week pump. Jeffsj
jeffsj is offline  
post #3 of 8 (permalink) Old 09-16-2011, 06:33 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
My initial reaction would be one of the diaphragms is not sealed correctly



Hunterworks is offline  
 
post #4 of 8 (permalink) Old 09-16-2011, 11:50 PM Thread Starter
Member
 
Join Date: Nov 2008
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Ok, I will take them back apart and check them then. If I run it with the plenum off how much bouncing are the slides supossed to do? I think mine are bouncing. It is weird if the diaphragms didn't seal though, as they seated in the groove very well. I am a pwc tech and have done literally thousands of pumper carbs, and some cv carbs on the jet skis so I am at least somewhat versed on working with carbs. Couple more questions, do you think my jets are close? I am at sea level. And if the fuel pump maybe has a problem, can I test with a rhino style high output mikuni pump (70ltr pr hr). This is the same one we use on some jet skis, and I have a brand new one here. I just don't know what the rating on the stock pump is though.
ultimate1 is offline  
post #5 of 8 (permalink) Old 09-17-2011, 06:38 AM
Junior Member
 
jeffsj's Avatar
 
Join Date: Sep 2011
Location: Natural Dam, Arkansas
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Garage
I was having a problem with my diaphragm not sealing this week while rejetting. It seems it had dried and shrunk a bit. Some magic lube silicone gel revitalize it. My rear slide would not open at all. Only ran on 1 cylinder. Its funny you should ask about the rhino pump. I messed around with my rex lean popping for months. It gradually got worse and wouldn't run. Took it to the dealer and we chased it down in about 15 min. All they had in stock was a rhino pump and looked similar enough i thought I'd try it. You have to shave the mounting bracket a touch but I've been running it for over a year with no issues. It seems it was about half the price too.
jeffsj is offline  
post #6 of 8 (permalink) Old 09-17-2011, 07:27 AM
Member
 
Jaminjer's Avatar
 
Join Date: Apr 2009
Location: Everett, WA
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
jeffsj do you have a picture or link to the gel you used. I had same problem with diaphram shrinking and bought a new one. Sure would be cheaper the lube.
Do you have a part number on the rhino pump?
Thanks

2008 LE, MSA M16 14" Beadlocks with 30" Zillas, Dyna CDI, Dyna hot coils, H2o temp & gas gauges, PRP seats & 5 pt harness, Trailarmor steering stabilizer, Odyssey PC925, Walker Evans Shocks, Hunterworks overdrive clutch cover, dasa plenum rings. Rugged radio RRP350 intercom with vertex VX2200 radio and H43 headphones
Jaminjer is offline  
post #7 of 8 (permalink) Old 09-17-2011, 07:55 AM
Junior Member
 
jeffsj's Avatar
 
Join Date: Sep 2011
Location: Natural Dam, Arkansas
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Garage
No. I don't really have either. Out of town right now. The lube is an Oring lube used on water fittings and stuff. Rainbow also makes a similar product. Maybe google it? If you haven't found anything, remind me in a few days and I'll get a pic to you. All i really know is that its a rhino pump. There probably aren't that many different ones. edit: aladin 630 magic lube. Its actually a teflon base. It came right up on google. Good stuff!
jeffsj is offline  
post #8 of 8 (permalink) Old 09-18-2011, 07:41 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by ultimate1 View Post
Ok, I will take them back apart and check them then. If I run it with the plenum off how much bouncing are the slides supossed to do? I think mine are bouncing. It is weird if the diaphragms didn't seal though, as they seated in the groove very well. I am a pwc tech and have done literally thousands of pumper carbs, and some cv carbs on the jet skis so I am at least somewhat versed on working with carbs. Couple more questions, do you think my jets are close? I am at sea level. And if the fuel pump maybe has a problem, can I test with a rhino style high output mikuni pump (70ltr pr hr). This is the same one we use on some jet skis, and I have a brand new one here. I just don't know what the rating on the stock pump is though.
They bounce bad with no air box

If you don't have the TPI valves or two 1 1/2" hole in the lid then those jets are gonna be too big too



Hunterworks is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Todd @ Hunterworks 4x4pac Kawasaki Teryx General Discussions 1 02-16-2011 11:40 PM
Stock jetting specs? Todd? Jaybo700R Kawasaki Teryx Performance Discussions 22 08-16-2010 05:28 AM
Hunterworks MSD Attn: Todd wilder105 Kawasaki Teryx Performance Discussions 3 03-23-2010 10:34 PM
HW Todd Wrecked his motorcycle Hunterworks Off-Topic Discussions 11 06-06-2008 03:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89