cdi on teryx? - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Kawasaki Teryx Performance Discussions Kawasaki Teryx performance discussions.
Engine mods, CDI boxes, exhausts, etc.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 (permalink) Old 07-24-2008, 07:24 PM Thread Starter
Senior Member
 
Join Date: Jun 2008
Posts: 604
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
cdi on teryx?

i just added a dynatek cdi on my stock teryx and here is the questions....after i test rode it on the open highway...my top speed is up to 60 mph on the factory speedometer....and seems quicker from a dead stop...and then today i rode it a little more and tried another top speed run...i hit 60 kindly quick and was hoping for a 61 but then it cut out like it was running out of gas but i had a half of tank..i slowed back down to around 50 and kicked it back down and it started to stutter like it was running out of fuel....any ideas what might be the problem?air filter is clean also.
whitey is offline  
Sponsored Links
Advertisement
 
post #2 of 24 (permalink) Old 07-24-2008, 07:36 PM
CommanderTalk.com
 
dieselpowered's Avatar
 
Join Date: Feb 2008
Location: Peoria, AZ
Posts: 2,799
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Hmmm interesting...could be a problem with the unit, I will let Todd read this and give his ideas since he has tested a lot more than me.




AllTerrainJournal.com --> www.AllTerrainJournal.com

I support every man and women in the armed forces, I wish you all the best and thank you!

2008 Kawasaki Teryx | 840cc BBK w/ stage III cams | FST long travel and HD steering | Twisted Stitch seats | FST cage | Muzzy dual exhaust | Dynatek prog CDI | aFe intake | HiPer carbon fiber beadlocks | Goodyear MT/Rs | Crow restraints | SafeGlo LED and FO whips | NightOwl HID conversion | Edge series 40" LED lightbar | Fuego Dual HID lights | Dalton clutch kit and OD cover | Full audio | Navigation | Power steering | TrailTech Vapor computer | Factory UTV skids | Airtite Art custom paint | Maier plastics
dieselpowered is offline  
post #3 of 24 (permalink) Old 07-24-2008, 07:39 PM
Senior Member
 
NEVERENOUGH's Avatar
 
Join Date: Mar 2008
Location: Chino Valley Az
Posts: 722
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Yeah I would like to hear what Todd has to say. Bet he can tell you what to do for sure he is the man.

Too much is neverenough
2003 duramax dually for towing
2004 Gearbox toyhauler 30fs
2006 limited yfz 450 mine
2003 Pred 500 wifes
1986 4trax 250R sons
1997 300ex daughter
2006 250ex daughter
2008 Teryx ours
NEVERENOUGH is offline  
 
post #4 of 24 (permalink) Old 07-24-2008, 07:48 PM Thread Starter
Senior Member
 
Join Date: Jun 2008
Posts: 604
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
i would to hear from [THE MAN] and see then before i go back to factory cdi.could it be the jetting?
whitey is offline  
post #5 of 24 (permalink) Old 07-24-2008, 07:50 PM
Member
 
Join Date: Feb 2008
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by whitey View Post
i just added a dynatek cdi on my stock teryx and here is the questions....after i test rode it on the open highway...my top speed is up to 60 mph on the factory speedometer....and seems quicker from a dead stop...and then today i rode it a little more and tried another top speed run...i hit 60 kindly quick and was hoping for a 61 but then it cut out like it was running out of gas but i had a half of tank..i slowed back down to around 50 and kicked it back down and it started to stutter like it was running out of fuel....any ideas what might be the problem?air filter is clean also.
That is the rev limiter. And i'm not talking about the stock rev limiter. The way the Teryx is geared, that is all it will do without modifying the sheave or gearing.

Benchmark Performance
760-484-0986
s2k1 is offline  
post #6 of 24 (permalink) Old 07-24-2008, 08:25 PM Thread Starter
Senior Member
 
Join Date: Jun 2008
Posts: 604
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
yea i understand that it is geared low but why is it acting like its running out of gas and then misses even when around 50?
whitey is offline  
post #7 of 24 (permalink) Old 07-25-2008, 06:45 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I have not idea!! Gotcha!!

I don't think it is the rev limiter. Not sure on jetting, it should do it everytime if it was jetting.

Bad CDI possible.

Fuel filter, possible.

If you know anyone close who has another CDI then try it.

I think you guys have too much faith in me, it will set me up for failure!!



Hunterworks is offline  
post #8 of 24 (permalink) Old 07-25-2008, 07:07 AM Thread Starter
Senior Member
 
Join Date: Jun 2008
Posts: 604
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
the unit only has 450 miles on it.....the cdi has been on there for about 15 miles.i will have to wait until a frind of mine gets his cdi before i can swap them out.i will do more testing this evening.
whitey is offline  
post #9 of 24 (permalink) Old 07-25-2008, 04:49 PM
Senior Member
 
NEVERENOUGH's Avatar
 
Join Date: Mar 2008
Location: Chino Valley Az
Posts: 722
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Todd sorry for all of the pressure don't want to see you fail. You are just so dang knowledgeable that we tend to lean on you for your help.

Too much is neverenough
2003 duramax dually for towing
2004 Gearbox toyhauler 30fs
2006 limited yfz 450 mine
2003 Pred 500 wifes
1986 4trax 250R sons
1997 300ex daughter
2006 250ex daughter
2008 Teryx ours
NEVERENOUGH is offline  
post #10 of 24 (permalink) Old 07-25-2008, 07:07 PM
Member
 
Join Date: Feb 2008
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by whitey View Post
yea i understand that it is geared low but why is it acting like its running out of gas and then misses even when around 50?
I think I misread your original post. Low 60s is all it will do for mph due to gearing. I thought you were describing an issue at that speed, and it would repeat when running it up from 50. My bad, I see what you meant now that I re-read it.
No magic bullet answer for that one.

Benchmark Performance
760-484-0986
s2k1 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88