Sandrail to Teryx - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-20-2013, 01:05 PM Thread Starter
Junior Member
 
Join Date: Dec 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Sandrail to Teryx

Sold my Sandrail and moved into a side by side.. picked up a 2008 Teryx, figured i get more use out of it. Hard to get to the dunes all the time and the sand rail ended up sitting in the garage too much. My new teryx has 4 seats, roll cage, 11:1 compression, Dynatek ignition, muzzy exhaust etc. I live in Tucson AZ. Other toys include lifted golf cart, shelby cobra.. and two rock star kids.

I'm having some issues with it cutting out at 40mph, stalls out and i have to wait 5 min to restart. I've re-jetted, changed ignition controller to the programmable dynatek (curve 3) and it still does it, almost like a limp mode. Very strange.. hope to get some help here. I'll post in the tech forum later and do some reading.

thanks great site
Fred
chiefshocker is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-22-2013, 12:05 AM
Moderator
 
tomanytoysnotnuftime's Avatar
 
Join Date: Jun 2008
Location: Fort Saskatchewan, Alberta, Canada
Posts: 383
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Check the fuel filter. It gets plugged up and after it sits the crud falls off the filter and it runs again for awhile until it gets plugged up again and so on and so on.

2012 VIBRANT Blue Teryx 4, Muzzy pro's, ECU reflash, custom cage & roof, windshield, 14" STI HD Beadlocks & 32x10x14 STI Roctane's/Tatou 4S Tracks, Rigid Lights, Custom bumpers, Warn XT4000 winches front & rear, bedlift

2010 black, FST 840 stage II cams, DASA intake & injectors, BF throttle bodies, Msd, Muzzy Pro`s, Snorkeled, Warn XT 4000, EMP, 2 seat race cage, Custom rear Radiator, Unisteer, STI HD beadlocks and 30x10x14 EFX motoclaws
tomanytoysnotnuftime is offline  
post #3 of 6 (permalink) Old 12-22-2013, 11:08 AM Thread Starter
Junior Member
 
Join Date: Dec 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by tomanytoysnotnuftime View Post
Check the fuel filter. It gets plugged up and after it sits the crud falls off the filter and it runs again for awhile until it gets plugged up again and so on and so on.
Thanks, I did change the filter at the same time i rejetted and cleaned the carb.
chiefshocker is offline  
 
post #4 of 6 (permalink) Old 12-24-2013, 11:12 PM
Moderator
 
tomanytoysnotnuftime's Avatar
 
Join Date: Jun 2008
Location: Fort Saskatchewan, Alberta, Canada
Posts: 383
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Try replacing the dynatek ignition with the stock one if you have it, they weren't the most dependable units out there.

2012 VIBRANT Blue Teryx 4, Muzzy pro's, ECU reflash, custom cage & roof, windshield, 14" STI HD Beadlocks & 32x10x14 STI Roctane's/Tatou 4S Tracks, Rigid Lights, Custom bumpers, Warn XT4000 winches front & rear, bedlift

2010 black, FST 840 stage II cams, DASA intake & injectors, BF throttle bodies, Msd, Muzzy Pro`s, Snorkeled, Warn XT 4000, EMP, 2 seat race cage, Custom rear Radiator, Unisteer, STI HD beadlocks and 30x10x14 EFX motoclaws
tomanytoysnotnuftime is offline  
post #5 of 6 (permalink) Old 12-28-2013, 06:28 PM Thread Starter
Junior Member
 
Join Date: Dec 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
shoot, i bought it without the stock ignition. i feel like it might be a fuel pump issue
chiefshocker is offline  
post #6 of 6 (permalink) Old 12-29-2013, 01:46 PM Thread Starter
Junior Member
 
Join Date: Dec 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
So now i'm thinking its the fuel pump.. it has a high output mukini in it and i think its too much .. anyone have a stock pump they want to sell or direct me to a cheap alternative. thanks
chiefshocker is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88