Hello help needed - Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-01-2010, 11:31 AM Thread Starter
Junior Member
 
Join Date: Jun 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Hello help needed

Hi Guys I bought a New 08 Teryx about a week ago and my first big ride was Sunday. I loved the machine but had an issue I am not sure How to fix. When driving through water up to the floor board it will miss and sputter real hard to keep running. If I get out of the water and keep running for 5 min or so it will fianlly clear up. I have dragon fire CDI and Dyntech hot coils and these are mounted the closest to where the water level was and I am wondering if they get wet and cause my problem. If so wich would you suspect first and what should I do they are brand NEW?
redteryx08 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-01-2010, 09:52 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Might have been ingesting steam



Hunterworks is offline  
post #3 of 9 (permalink) Old 06-01-2010, 10:00 PM Thread Starter
Junior Member
 
Join Date: Jun 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
do you realy think it would run bad for so long i also have an AFE cold air intake and i never felt any steam coming up from behind the seats
redteryx08 is offline  
 
post #4 of 9 (permalink) Old 06-01-2010, 10:04 PM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Hard to say but doubt that running bad that long, missed that part the first time.

It's the water though!! LOL.

Put dielectric grease on all connections



Hunterworks is offline  
post #5 of 9 (permalink) Old 06-02-2010, 12:51 AM
Moderator
 
tomanytoysnotnuftime's Avatar
 
Join Date: Jun 2008
Location: Fort Saskatchewan, Alberta, Canada
Posts: 383
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Spark plug boots.

2012 VIBRANT Blue Teryx 4, Muzzy pro's, ECU reflash, custom cage & roof, windshield, 14" STI HD Beadlocks & 32x10x14 STI Roctane's/Tatou 4S Tracks, Rigid Lights, Custom bumpers, Warn XT4000 winches front & rear, bedlift

2010 black, FST 840 stage II cams, DASA intake & injectors, BF throttle bodies, Msd, Muzzy Pro`s, Snorkeled, Warn XT 4000, EMP, 2 seat race cage, Custom rear Radiator, Unisteer, STI HD beadlocks and 30x10x14 EFX motoclaws
tomanytoysnotnuftime is offline  
post #6 of 9 (permalink) Old 06-02-2010, 07:08 AM Thread Starter
Junior Member
 
Join Date: Jun 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thanks for the help i will try die electric grease. Is there a special spak plug boot or just put die electric grease in them.
redteryx08 is offline  
post #7 of 9 (permalink) Old 06-02-2010, 07:33 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
just the grease



Hunterworks is offline  
post #8 of 9 (permalink) Old 06-02-2010, 09:21 AM Thread Starter
Junior Member
 
Join Date: Jun 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thanks for your help! I have another Question you could proably answer. I have a dragon fire CDI and it came with it so i am not sure if it is the programable one. Is there any to tell by looking or a part number or something. I think I have a slight miss at 1\8 to 1\4 throtle like I have seen everyone talking about.
redteryx08 is offline  
post #9 of 9 (permalink) Old 06-02-2010, 10:43 AM
Senior Member
 
Join Date: May 2008
Posts: 3,999
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by redteryx08 View Post
Thanks for your help! I have another Question you could proably answer. I have a dragon fire CDI and it came with it so i am not sure if it is the programable one. Is there any to tell by looking or a part number or something. I think I have a slight miss at 1\8 to 1\4 throtle like I have seen everyone talking about.
If it does not have any extra connections coming out of it then no.



Hunterworks is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forums: Kawasaki UTV Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Whisper MAP needed brettrown Kawasaki Teryx Performance Discussions 8 06-01-2010 06:48 AM
New Roof Needed, WTB HiDesertTeryx Kawasaki Teryx General Discussions 0 09-09-2009 04:16 PM
Any New Forums Needed? dieselpowered TeryxHQ Help Desk 0 03-09-2009 02:42 AM
Needed some lights! Lobo Kawasaki Teryx General Discussions 0 11-02-2008 01:52 PM
Jet Kit help needed mikec570 Kawasaki Teryx Performance Discussions 10 08-06-2008 11:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89