Teryx HQ banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
need some help with an 08...I've been having problems with it stalling at idle. I have installed new plugs and pulled the carbs to check the air screw and also tried spraying it down with carb cleaners to clean out the jets, etc.

It is starting fine right now and if you run it, it will run fine, however when left to set at idle, it will soon start to slightly sputter and then shut off. It seems (although could be my imagination) that it gets worse as it warms up.

Thanks for any ideas you guys have...for the info I am running a new UNI filter on it, it has a dynojet exhaust kit on it, stock exhaust.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I have not adjusted the valves, I have just started seeing this issue pop up when doing some searches on here and the internet. I just bought the bike used this summer and it was running fine when I got it, then I let it set for a couple weeks and started having the idle problem....at first it would not idle at all unless it was choked, but once I took the plugs out and cleaned them (and have since changed them) it would idle for a little while and then shut off, unless I was on the gas.


BTW, installed your UNI filter setup on the bike....easy as pie and a heckava lot better than the stock filter on it. Thanks
 

·
Registered
Joined
·
3,999 Posts
I have not adjusted the valves, I have just started seeing this issue pop up when doing some searches on here and the internet. I just bought the bike used this summer and it was running fine when I got it, then I let it set for a couple weeks and started having the idle problem....at first it would not idle at all unless it was choked, but once I took the plugs out and cleaned them (and have since changed them) it would idle for a little while and then shut off, unless I was on the gas.


BTW, installed your UNI filter setup on the bike....easy as pie and a heckava lot better than the stock filter on it. Thanks
Gonna play devils advocate here, why are you sitting around idling for any length of time?

If pulling the choke helps then turn the mixture screws out some. Still think you need to adjust valves.

Thanks for the air filter order!!

Todd
 
1 - 4 of 4 Posts
Top