Teryx HQ banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 2009 Teryx I purchased in Mid-February.

This last weekend I was about 5-7 miles into a dune ride and the engine lost power and shot some white smoke out the exhaust. I let it cool for 30 mintues and when I took off again there was a ton of white smoke and then all of a sudden it was gone. This happened on my previous trip also. This is a stock motor, no mods at all.

What is causing this?

Is there any other engine related issues I should address over the summer?

Thanks!
 

·
Registered
Joined
·
85 Posts
Hi
I have a 2008 and about 2 weeks ago I was running in the rain and had 2 people and running hard and my teryx blew white smoke and quit. choked it and it restarted but run poorly. It may need a hunterworks stop kit which recycles the oil or make sure your oil level is right at full or just below full and it shouldn't do it again. Good luck :wave:
 

·
Registered
Joined
·
260 Posts
I have a 2009 Teryx I purchased in Mid-February.

This last weekend I was about 5-7 miles into a dune ride and the engine lost power and shot some white smoke out the exhaust. I let it cool for 30 mintues and when I took off again there was a ton of white smoke and then all of a sudden it was gone. This happened on my previous trip also. This is a stock motor, no mods at all.

What is causing this?

Is there any other engine related issues I should address over the summer?

Thanks!
you are only the 300th person with that same question. do a search and you will find all the answers you are looking for.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
you are only the 300th person with that same question. do a search and you will find all the answers you are looking for.
Did you feel good when you typed this? What a tool! If you have nothing to contribute don't read it. It's easy.
 

·
Registered
Joined
·
260 Posts
many of us get tired of the same old stuff over and over, do a search, it's easy! third word from right, top of page. probably been covered 60-70 times already, maybe hundreds. don't get mad at me because your lazy!
 

·
Registered
Joined
·
29 Posts
make sure you get the hw air filter kit too, i waited too long and lost the whole motor in my 09' because of kawis crappy design.
 

·
Registered
Joined
·
3 Posts
I have a 2009 Teryx I purchased in Mid-February.

This last weekend I was about 5-7 miles into a dune ride and the engine lost power and shot some white smoke out the exhaust. I let it cool for 30 mintues and when I took off again there was a ton of white smoke and then all of a sudden it was gone. This happened on my previous trip also. This is a stock motor, no mods at all.

What is causing this?

Is there any other engine related issues I should address over the summer?

Thanks!
Happened to me this weekend. Noticed tail pipe was oily so assumed oil got into cylinder. Checked the air filter and while doing so had to remove my jacket off of the console between passenger and drivers seats. TA DAAAAA, I think while moving my coat fell in front of the air inlet, a partial vacuum created and crank case oil sucked into engine. Once obstruction removed engine started fine and blew smoke for about 5 - 10 minutes.
 
1 - 9 of 9 Posts
Top