Teryx HQ banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Well I now have a 2010 teryx with a hole 16 hours on it with major tranny probs. Has Anyone herd of something being up with these? I work at one of the biggest dealers here in PA and sell almost every make out there and haven't had any 2010 models of these come back yet but we also haven't sold a ton either. What happen here was I went into some mud nothing major but did get stuck since it had a deep rut on the right side and not the left so I used the dif lock and tried to work my way out which didn't work anyhow and had to winch it out. After I was out and put this thing back in gear I herd this crazy loud noise coming from the bell housing side and figured it was the belt or something of that sort. Well after taking it back to the shop it seems it's in the trans.... WTF. I can't believe I only have 16 hours on this thing and this happened. I also have a rhino and that's 07 with not one prob yet so I don't get what's up with this teryx. I am thinking I should have picked up something else. Has anyone herd of any trans probs in the 2010s?
 

·
Registered
Joined
·
516 Posts
I don't think they changed anything in the driveline for the 2010, very few problems but there have been some, normal for clunking but not if you have some major noises. Let us know what blew up, sure it is not in the clutching or the belt??? Have you torn it apart yet? Does it make the noise in all gears, high/low/reverse - maybe the shift linkage is out of adjustment or being new possibly someone left it loose. Welcome to the site!
 

·
Registered
Joined
·
255 Posts
Check the shift linkage before you do anything else, you may be lucky and only need an adjustment!!
 
1 - 3 of 3 Posts
Top