Teryx HQ banner
1 - 11 of 11 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2013 Teryx 4. I can jump start it, it will run for a couple minutes then the EPS light comes on and power steering won't work, within seconds the check engine light comes on and the motor stops. The battery is brand new. Please give me some ideas on what to check or what might be wrong. Thanks.
 

· Registered
Joined
·
6 Posts
I have a 2013 Teryx 4. I can jump start it, it will run for a couple minutes then the EPS light comes on and power steering won't work, within seconds the check engine light comes on and the motor stops. The battery is brand new. Please give me some ideas on what to check or what might be wrong. Thanks.
I am having the exact problem this weekend. Any luck figuring out what was wrong?
 

· Registered
Joined
·
6 Posts
I have a 2013 Teryx 4. I can jump start it, it will run for a couple minutes then the EPS light comes on and power steering won't work, within seconds the check engine light comes on and the motor stops. The battery is brand new. Please give me some ideas on what to check or what might be wrong. Thanks.
Did you ever find out anything. I'm having the same issue
Please let me know if you figure out the problem. Thanks
 

· Administrator
Jesus is Lord
Joined
·
27 Posts
Mine was the battery. I learned a bunch of components on these things rely on a constant small but solid pull off the battery. Even if your battery is new I would check it out thoroughly before moving on.
This. Had the same issue with mine. EPS stopped working, but IIRC everything else functioned properly. Replaced it with a good odyssey battery and never had another problem.
 

· Registered
Joined
·
2 Posts
I have a 2013 Teryx 4. I can jump start it, it will run for a couple minutes then the EPS light comes on and power steering won't work, within seconds the check engine light comes on and the motor stops. The battery is brand new. Please give me some ideas on what to check or what might be wrong. Thanks.
I have a 2013 Teryx 4. I can jump start it, it will run for a couple minutes then the EPS light comes on and power steering won't work, within seconds the check engine light comes on and the motor stops. The battery is brand new. Please give me some ideas on what to check or what might be wrong. Thanks.
 

· Registered
Joined
·
3 Posts
I had the exact same issue about a year ago on my 2013 Teryx4. I replaced the battery and in a couple days later the problem returned. My stator was bad and had to be replaced for $700. Fast forward a year and a half later and today I am back at Kawasaki for another new stator, voltage regulator, and a complete new wiring harness. $3385.57. The technician said he was on the phone with Kawasaki for four hours before diagnosing the problem. The wiring harness lost its ability to carry the voltage and the charging system was working so hard it killed the stater and regulator. The technician told me that he has at least two other machines with the exact same problem right now. One is a 2013 model and the other is a 2014. Since this work was done at Kawasaki, the parts and labor have a one-year warranty. But you can bet the buttons on your shirt that this piece of junk will be out of my hands within a year.

p.s. I found this thread because I took off work and drove over an hour to pick up my machine and the power steering doesn’t work. There’s no EPS light on, no codes, and the technicians are at a loss so I’m searching the Internet to see what I can find.
 
1 - 11 of 11 Posts
Top