Teryx HQ banner

1 - 20 of 21 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Guys, anyone know of a plug and play HID for the 2010's yet? I need to pick up a set and can't find any that don't require cutting and fitting. I'm really looking for something plug and play. I'm hoping to keep my headlight bucket and lens completely stock.

Thanks for any help.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #5
Marty, those look pretty nice. Have you been happy with them? Was there a huge difference in light output (sometimes they embellish the picture on websites) and lastly, were they truly plug and play?

If you say they are pretty good, I'm going to order a pair and then pick up a Tribal Whips LED Stick for my roof.

Let me know what you think, good or bad on the HID's.

Chris
 

·
Registered
Joined
·
630 Posts
Marty, those look pretty nice. Have you been happy with them? Was there a huge difference in light output (sometimes they embellish the picture on websites) and lastly, were they truly plug and play?

If you say they are pretty good, I'm going to order a pair and then pick up a Tribal Whips LED Stick for my roof.

Let me know what you think, good or bad on the HID's.

Chris
Chris

We were the first with the Hi/low HID kits and we are 100% plug and play, ask anybody who has our kits and they are very satisfied. Look in our vendor section.

Also we sell Tribal whips as well.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #7
Endi, I know you guys are good. That is why I sent you an email before I even posted this thread!!:) Last time I talked to you on the phone, SXS still didn't have a plug and play solution for the 2010. I went back and looked at your vendor forum but didn't see any updates before I posted. I saw 08 and 09 but no 2010.

If that has changed, reply to my email and we can talk. I need to get something going within the next few days.

Thanks!
Chris
 

·
Registered
Joined
·
630 Posts
Guys, anyone know of a plug and play HID for the 2010's yet? I need to pick up a set and can't find any that don't require cutting and fitting. I'm really looking for something plug and play. I'm hoping to keep my headlight bucket and lens completely stock.

Thanks for any help.
Opppsss... I should of read it fully, headed back from the UTV Jam so I'm off my crackberry.

We are still doing the R and D on it, this is one on the top of our list. We really want to offer a true hi low plug and play kit. As soon as we are ready ill hit you up as a tester.
 

·
Registered
Joined
·
116 Posts
The ones i have are the only ones i found that were for 2010 teryx. they also sell a 2008-9 kit, so i knew there had to be a difference. They are Eagle Eyes which i had on my Rhino for 2 years with no issues. Know alot of other people who ran the Eagle Eyes with no issues either. Thats why i bought them again. They are only single beam, which is what i wanted anyway. They are very bright and plug and play.
 

·
Registered
Joined
·
32 Posts
I know this is an old post but I just got my Eagle Eyes installed and yes they are true plug and play and no bulb or housing modification. Just reuse your gaskets from your stock headlights and it is sealed and tight(no silicone needed). wvyankee2, did you find a good place mount your ballasts. If so can you explain or send a pic. I was in a hurry and just kinda zip tied them up quick so I could look at them.
 

·
Registered
Joined
·
32 Posts
Thanks man. I got mine done yesterday. I like yours too though. Did you use that bracket that came with them to zip tie them against. I zipped my ballasts flat where your are vertical and then the black box to the front of the headlight bucket at the front of the hood. I'm new to HIDs and didn't know if that ballast needed some breathing room so I didn't put the black box together with it.
 

·
Registered
Joined
·
116 Posts
There is a bracket with 2 holes in it that comes up off the frame to the hood. The ballast holes are threaded. I found a screw that fit those threads and screwed the one side tight. Then used a zip tie on the other side because the holes did not line up. I think you will like them. I had these on my Rhino for 2 years and had good luck.
 

·
Registered
Joined
·
32 Posts
Alright thanks. Which fuse did you upgrade to 20 amp? Or did you run a relay.
 

·
Registered
Joined
·
32 Posts
I was thinking that was the correct fuse as I turned on the lights with the other 3 pulled out, but wasn't for sure. Mine have no issues as of yet, but some of my buddies have other kits and theirs would work great for a few weeks and then start having one not come on and would have to either run with one out or turn them off and on alot before the other one fired. Now at least I know I shouldn't have a problem at all. Thanks.
 

·
Registered
Joined
·
630 Posts
I have a 2010 that I would like to have HID's on. SXS Customs do you have the High Low system out yet?
Nothing that is a plug and play solution but we are testing a Hi/low upgrade kit. The kit is going to be field testing in few weeks, a very cool solution.
 

·
Registered
Joined
·
5 Posts
Any updates to suppliers of the HID kits for 2010-11 model year?
Giant has been out of stock for awhile.
Anyone ever modify a bulb to work?

Thanks
 
1 - 20 of 21 Posts
Top