Teryx HQ banner

1 - 6 of 6 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
Road today and the Rex starts puking antifreeze out... no temp light on either. so found the cooling fan breaker under the seat tripped. reset and came right on.
O and have heard people say you cant add water on trail.. sure you can fill the reservoir and start engine. add as needed.
just wondering about the circuit breaker. are they weak or just POS.
thanks all
Crab
 

·
Registered
Joined
·
31 Posts
POS! mine went on first ride got one from auto zone and no prob since
 

·
Registered
Joined
·
526 Posts
Took mine out and install a in-line fuse instead of the breaker
 

·
Registered
Joined
·
78 Posts
had same issue last weekend at ocotillo. breaker would not reset though. bought a 15amp from an electronics store and all works great now. I was able to add water through the overflow bottle while riding. took off hood and checked radiator level and it sucked water from the overflow just fine.

I did discover that you can jumper the sensor from the radiator and have fan on all the time if needed while riding.
 

·
Registered
Joined
·
3 Posts
Thank you to all that posted this I just bought an 09 and had this problem dealer has it cause still under warranty. Does anyone have a part number or what is the proper breaker for this to make it a 15 AMP. Has anyone found a way to add anti-freeze on the trail, make the cap more accessible while on the trail due to mine was bone dry when I had this issue.
 
1 - 6 of 6 Posts
Top