Teryx HQ banner

1 - 8 of 8 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
ive been noticing alot of u guys talking bout cooling problems,ive had the same issue the past few months ,decided to pull the thermostat out to see if it was my problem.it was stuck shut and would not open so i took it completly out and let it run for bout a hour working the throttle.so far no problems.gone run the hell out of it tomarrow to see if this fixed my problem. didnt know if any of you with this problem had tried this.
 

·
Registered
Joined
·
62 Posts
Discussion Starter #4
thanks todd ,yea ive been trying to make it be somthing else ,gona pull it out this weekend,it does have air bubbling in the waterin the radiator
 

·
Registered
Joined
·
62 Posts
Discussion Starter #5
When i pull the heads do i need to put new rings and hone cylender again or just gaskets it only has 480 miles since it was done.
 

·
Registered
Joined
·
3,999 Posts
Should be fine with just gaskets but one thing I would do is make sure you don't have a warped head.

One issue with head gaskets is making sure both the head and cylinder are very clean and dry plus not touching the gasket on the sealing surface..

I would put aftermarket valves and springs in if you have not already.

Todd
 

·
Registered
Joined
·
62 Posts
Discussion Starter #7
every thing in the top is new big kev did my head work they should be rite,guess i didnt get a good seal when i put it together .should i use a kawi gasket or is there some better than factory. thaks for all your info not many people like to give info unless theres some green backs involved .
 
1 - 8 of 8 Posts
Top