Teryx HQ banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
A lil stumped here. The engine runs fine but has a clack clack clack sound every few seconds. Valves check out fine, compression is fine, leak down is fine. It's in the front cylinder and loudest on time chain side. Pulled rocker box and all looks fine. Chain tensioner works. Could it be the compression release? It seams to working correctly.

IDEAS?
 

·
Registered
Joined
·
3,999 Posts
A lil stumped here. The engine runs fine but has a clack clack clack sound every few seconds. Valves check out fine, compression is fine, leak down is fine. It's in the front cylinder and loudest on time chain side. Pulled rocker box and all looks fine. Chain tensioner works. Could it be the compression release? It seams to working correctly.

IDEAS?
Are you saying it does not do it all the time?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Kinda. It's normal for few seconds then it does like 3-4 clanks then back to normal. It keeps doing this over and over. After I put it back together cuz I didn't see anything I was looking at the book. I noticed that the timing guide for the tension side is long in book. In the head if I remember correctly it was short. I'm thinking it broke and allowing chain to slap. I'm going to tear it back down tomorrow and take another peek. Will let you guys know my findings.
 

·
CommanderTalk.com
Joined
·
2,799 Posts
Is your belt slapping the cover?
 
1 - 6 of 6 Posts
Top