Teryx HQ banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello, I have a 2015 T4. This weekend I went to get it off the trailer and would not start like battery was dead. It will jump start but eps light comes off and on and kinda cuts out if I do anything besides putt around engine dies and won’t start. I can even kill it by pushing the horn. It has original battery I will probably replace but seems like it’s something else. 2000 miles and never been in deep water or anything crazy. Any help would be greatly appreciated. Thanks
 

·
Registered
Joined
·
4 Posts
Hello, I have a 2015 T4. This weekend I went to get it off the trailer and would not start like battery was dead. It will jump start but eps light comes off and on and kinda cuts out if I do anything besides putt around engine dies and won’t start. I can even kill it by pushing the horn. It has original battery I will probably replace but seems like it’s something else. 2000 miles and never been in deep water or anything crazy. Any help would be greatly appreciated. Thanks
Mine just did the same thing today. Any news on what it was?! Then the oil light came on and was flashing too. I don't get it
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
So I found out these machines need a constant small but solid pull off battery to run almost everything. I would have never guessed that was the problem based on how it was acting and I got a good reading on volt meter. Replaced battery and took care of the problem
 

·
Registered
Joined
·
1 Posts
So my 2021 4s just started doing the same thing just like you never in deep water and just had just rolled over 1000 miles when it came on also it locks it's self in dif lock and will only run and drive around 50yd after jumping the battery. Was the battery replacement a permanent fix for you?
 
1 - 5 of 5 Posts
Top