Teryx HQ banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i have a 09 sport it has 4000km on it. one day i was riding it start to spudder backfire low power and seem to be runing on one cylinder so i put two new coils in it.It started up good runs strong, you go for a mile or so it starts doing it againe i took the fuel pump out and took it a part. There was a little bit of junk on the filter i cleand it off .it pumps the right amount of fuel at start up 3.5 0z but is seems like it runs good and till that is brun t up and then it boggie and spudding and backfireing if some one can help or give me some ideas that would be grate!!

motosaki
 

·
Registered
Joined
·
8 Posts
Good luck I have been fighting the same problem and finally gave up and took to the dealer and have not heard back yet I will post when I found out what they find.
 

·
Registered
Joined
·
2 Posts
i have an 09 with 20 hours wouldnt start the other night took it to the dealer. I got the call today it was the ecm it turns out kawasaki is having a problem with them burning out the pin for the fuel pump just melts away. not sure if you guys are having same problem but it may be something to look into.
 

·
Registered
Joined
·
1 Posts
I have an 09 Kawaski Teryx that after about 20 hours sometimes it starts right up and others time it cranks and will not start. Its been to the dealer twice and they cant seem to fix it. Any suggestions?
 

·
Registered
Joined
·
8 Posts
After a long time at the dealer they finally replaced the the fuel pump and to my amazement they did it under warrentee...The machine has 3k and is a year old...
 
1 - 7 of 7 Posts
Top