Teryx HQ banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi Guys I bought a New 08 Teryx about a week ago and my first big ride was Sunday. I loved the machine but had an issue I am not sure How to fix. When driving through water up to the floor board it will miss and sputter real hard to keep running. If I get out of the water and keep running for 5 min or so it will fianlly clear up. I have dragon fire CDI and Dyntech hot coils and these are mounted the closest to where the water level was and I am wondering if they get wet and cause my problem. If so wich would you suspect first and what should I do they are brand NEW?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
do you realy think it would run bad for so long i also have an AFE cold air intake and i never felt any steam coming up from behind the seats
 

·
Moderator
Joined
·
383 Posts
Spark plug boots.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Thanks for the help i will try die electric grease. Is there a special spak plug boot or just put die electric grease in them.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Thanks for your help! I have another Question you could proably answer. I have a dragon fire CDI and it came with it so i am not sure if it is the programable one. Is there any to tell by looking or a part number or something. I think I have a slight miss at 1\8 to 1\4 throtle like I have seen everyone talking about.
 

·
Registered
Joined
·
3,999 Posts
Thanks for your help! I have another Question you could proably answer. I have a dragon fire CDI and it came with it so i am not sure if it is the programable one. Is there any to tell by looking or a part number or something. I think I have a slight miss at 1\8 to 1\4 throtle like I have seen everyone talking about.
If it does not have any extra connections coming out of it then no.
 
1 - 9 of 9 Posts
Top