Teryx HQ banner

1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Ok guy's let me know, I tried yesterday and ended up back in the same spot it was, should the machine be in neutral, reverse, I would think reverse since thats the farthest the rod has to move, done that and it would not go into neutral. Im trying to get this clanking noise out when in low gear just ridding around slow with my little girl, I think the noise is due to the engine brake control, if so can it be disconnected? H E L P !!!!!!!!!!!!!! Allan
 

·
Premium Member
Joined
·
796 Posts
Put the car in Neutral...I adjust mine out first until I heard a little grind and then back the other way until the same thing happened...then I tightened it down right in between the 2 and it's never given me a problem since...

And the EBC has a small plug on top of your CV cover...you can just unplug it there for now and see how you like the ride...if you can live without it? Then you can go get a clutch cover from one of our forum vendors and toss the whole assembly out and save yourself a couple of lbs...DASARacing.com makes a really nice set up and also a billet cover to replace the whole assembly...
 

·
Registered
Joined
·
318 Posts
if u are trying to rid of the noise by adjusting linkage that wont work.. But if linkage is out of adjustment,, I put shift lever in position where neutral light would come on then adjust till lever was in correct position, worked for me.
 

·
Registered
Joined
·
5 Posts
Hey Allan, I just had the same problem with my 09. It made a really loud clunking noise slowing down in low or going down a hill in low. Sounded like it was falling apart. I put my lever in neutral and then loosened the two nuts on the linkage rod and then moved the rod until the green light came on. I had to adjust it a couple of times, seems like there is a little play there, even when the green light would come on I could still turn it almost a full rotation before the light would go off. I had to mess with it a few times before I got it right, but now no more loud noise. Also when mine was making the noise I could grab the lever when I slowed down and could feel the lever vibrating really bad. Hope this helps, good luck.
 

·
Registered
Joined
·
85 Posts
Hi
The 1/4" shift rod flexes due to is small size so I welded a 1/2" square tube in between the threads (1/2" square tubing about 12 inches long). Stopped flex and reduced clunk noise a lot with proper adjustment. Try it very easy to do.
 

·
Registered
Joined
·
2 Posts
linkage adjustment

so im currently deployed and we have two teryx's over here and im thinkin one needs a linkage adjustment but cant really find out how to do it so if anyone can help me with a site or link or anything that would be greatly appreciated.
 

·
Registered
Joined
·
2 Posts
dont really know much bout fixin it so if i had a manual or somthing like that it would be awsome, can some one point me in the right direction
 

·
Registered
Joined
·
1 Posts
Put the car in Neutral...I adjust mine out first until I heard a little grind and then back the other way until the same thing happened...then I tightened it down right in between the 2 and it's never given me a problem since...

And the EBC has a small plug on top of your CV cover...you can just unplug it there for now and see how you like the ride...if you can live without it? Then you can go get a clutch cover from one of our forum vendors and toss the whole assembly out and save yourself a couple of lbs...DASARacing.com makes a really nice set up and also a billet cover to replace the whole assembly...

Good info, thanks
 
1 - 8 of 8 Posts
Top