Teryx HQ banner

1 - 6 of 6 Posts

·
Registered
Joined
·
722 Posts
Discussion Starter #1
Ok so I thought I had it fixed but still not correct. I have an 08 with a muzzy std. bore and dynatec cdi. The air box is stock and so is the exhaust. It runs really good about 1/4 throttle then when you try to open it up it just dies out. It sputters and pops through the carbs. I have two washers on each needle and the jetting is I think 154 and 150. Is it still lean? When at idle it smells rich but I am not sure confused as hell.
 

·
Registered
Joined
·
722 Posts
Discussion Starter #3
Todd thanks I was hoping to get your imput. I stayed away from the exhaust because the machine is used for a variety of things one being hunting and was trying to keep it as quiet as possible. I know I need to get an air fuel gauge it is on the list. I am positive the slides are operating I had the air box off to be sure. I was thinking a little rich also but always heard popping through the carb was a lean condition. Is there any way maybe to make sure ie remove air box lid or remove exhaust tip to be sure before I tear into it again. Thanks for always helping out your knowledge on these machines is priceless.
 

·
Registered
Joined
·
3,999 Posts
IF you got the exhaust tip in, take it out, barely louder and 2.5 hp on our dyno

Could be the choke cable is binding and one or both of the chokes are on all the time. Check the Y in front of the shifter and below it, wrapped in heat tape with a wire tie top and bottom. Cut the top wire tie and unwrap some of the heat tape.

If that does not work you can call me at the shop and I will run thru some stuff with you, like asking you interview questions and see what might be it.
 
1 - 6 of 6 Posts
Top