Teryx HQ banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I just installed the Hunterworks carb/airbox kit and I have a question. I installed the recommended main jets for my altitude (3K-6K) and run my CDI on curve 1, both TPI vavles open and the stock exhaust with the spark arrestor out. It seems to pop quite a bit when I let off the gas. Is my mixture screw set incorrectly? Am I running rich or lean?It seems to run fine @ wide open throttle. Also, I have an HMF swamp series exhaust coming from Hunterworks, so once this is installed, do you think it will fix the problem? I appreciate the help!

Pikester
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Thanks Todd, will do! Thanks again for the super deal on the exhaust and all of the valuable "after the sale" support. It's nice to know there are people out there who still look to help out the customer & you are definitely one of those guys.

Pikester
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Todd,

I have the swamp series exhaust on (I like the way it sounds!) and I adjusted the mixture screw to 3 turns out, and now it seems it runs best with 1 TPI valve open & the other one closed. Is this OK? Will it allow me to open the other TPI valve as I go up in elevation? It still pops, but only occassionally, if I really get on it & then just let off, but it is much better. Also, what is the difference between the hunterworks curve & curve 1? Thanks for all the help!!

Pikester
 
1 - 7 of 7 Posts
Top