Teryx HQ banner

1 - 9 of 9 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
Would anyone know what is about to spill it's guts in my 08' Teryx. When you put it under a load in low 4x4 it pops like 2 weshed gears slipping on each other. It's pretty bad. Thanks in advance for any ideas.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #4
Guy's, thanks for your help. I don't know if it does it in 2wd or not yet. I was plowing snow yesterday with it and it is still sitting out on the trailer. It is like -10 wind chill out there today and I was going to wait until tomorrow to unload and clean it up. I alway's plow with it in low and had to finish the day plowing in high, (not good) but I have 30 driveways I plow with it and I had to get them all. I plowed all last year and 3 snows so far this year and it has worked awesome. I have been plowing these driveway's for 10 years now. I started with atv's and never had any ploblems with them. I bought the Teryx and it has worked great till this happened. When you plow with atv's/utv's you have to know the limit with them and I am easy on them in that respect. I was listening when it was popping and it sounded for sure in the trans. area. When it pops, you can feel the machine stop it's forward motion at the time of the pop, like a chain slipping a tooth on a sproket kind of thing. Thanks again guy's for any help here. I will check it in 2wd/lo tomorrow.
 

·
Registered
Joined
·
85 Posts
My teryx did the same thing and the shift tower was lose and would not hold it in low gear High was ok. I readjusted the shift linkage and everything work fine.:wave:
 

·
Registered
Joined
·
72 Posts
Discussion Starter #6
Well, the consensus here seems to be the shift linkage. I will look into that today. It will be great if that is the problem, an adjustment instead of a fix. Thanks guy's for taking the time out of your day to answer my question, it is very much appreciated.
 

·
Registered
Joined
·
526 Posts
Mine was the same as Filyn adjusted the linkage and all was good
 

·
Registered
Joined
·
72 Posts
Discussion Starter #9
Yea guy's it was the linkage. Plowed all day yesterday in low gear and no popping out of gear after the linkage adjustment. Thanks again for the help guy's.
 
1 - 9 of 9 Posts
Top