Teryx HQ banner

1 - 15 of 15 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter #1
Okay... I've just installed my 840 kit. I've got everything plugged in, and I'm ready to turn the key.

Only thing is, how do I update the settings in my MSD from the original 750 maps to the 840 maps I got from Muzzy?

I can't start it, because I need to change the curves first.

If I just turn the key on to Accessory it doesn't turn the MSD on. (the software on my laptop doesn't recognize the MSD to connect).

So, how do you program your MSD?
 

·
Registered
Joined
·
177 Posts
You have a hunterworks MSD right? I assume he has curves that will help you out.
 

·
Registered
Joined
·
167 Posts
Discussion Starter #3
Sorry dude, but you've missed the question.

I have curves already, I just don't know how to change them from the HW map to the Muzzy maps I got with the kit.

When you plug the MSD into the laptop, you have to "connect" them. My laptop isn't recognizing the MSD..... & I can't start the engine until I've changed the map.

I'm looking for advise from someone that's done this before.

Thanks though.
 

·
Registered
Joined
·
3,999 Posts
Sorry dude, but you've missed the question.

I have curves already, I just don't know how to change them from the HW map to the Muzzy maps I got with the kit.

When you plug the MSD into the laptop, you have to "connect" them. My laptop isn't recognizing the MSD..... & I can't start the engine until I've changed the map.

I'm looking for advise from someone that's done this before.

Thanks though.
This is going to sound like a smart ass answer but call Muzzy, they gave you the maps.

Or call me.

The Teryx MSD should connect easily. Once you have the software open and the MSD plugged in, go to top of screen, click on connect, window pops up and your MSD should show up in blue, then click connect again. If it does, the go to file, then open navigate to the file Muzzy sent you, click it then click open. IT will ask you if you want to send it, click yes or whatever I can't remember then it shows transfer complete. Turn screw to right number and go.

Also, don't trust a map for a engine kit, you need to back it up with a air/fuel ratio gauge.

Todd
 

·
Registered
Joined
·
318 Posts
It sounds like u dont have the msd software downloaded to ur computer if when plug it in it doesnt recognize msd? U can download the software at msd website.
 

·
Registered
Joined
·
318 Posts
Either that or your not getting a good connection to the msd via the usb, maybe some gunk in the msd port? Once u plug the msd in to pc and u have msd software up it should reconize msd connect right away, whether machine is on or not, msd doesnt even have to be connected to rex for that matter
 

·
Registered
Joined
·
167 Posts
Discussion Starter #7
So, does the key need to be on to connect?

I have the MSD software loaded. I've connected to the MSD in the passed just to see how it worked and it worked just fine.

Maybe there is some crap in the plug... That's what I'll try today.

I do have an A/F meter that I bought from you Todd. Maybe I give you a call today.

Thanks for the input guys.
 

·
Registered
Joined
·
3,999 Posts
So, does the key need to be on to connect?

I have the MSD software loaded. I've connected to the MSD in the passed just to see how it worked and it worked just fine.

Maybe there is some crap in the plug... That's what I'll try today.

I do have an A/F meter that I bought from you Todd. Maybe I give you a call today.

Thanks for the input guys.
Key does not have to be on.
 

·
Registered
Joined
·
1,434 Posts
I know when it comes to the programing on the MSD, I would trust Todd as much as anyone, he worked with MSD on the proto type for months before they released it to the users, If Todd can't help you on this nobody can, there are alot of good maps out there with other venders but Todd was working with the MSD before most ever got there hands on one.
 

·
Registered
Joined
·
301 Posts
Unfortunately I've found its difficult to get some laptops to recognize the MSD...(Usually older ones) and I haven't quite figured out if its the software causing it or if the USB ports simply aren't powerful enough to run the MSD.


Depending on the OS you're using you can... Right click "my computer" then click "manage" -> device manager -> Look and see if there is anything with a "?" by it with MSD. This will show you if the usb port is even recognizing the MSD.

If it is there you can double click on it and then click update drivers and see if it will automatically fix it for you.

Just some things to try and if that doesn't work you'll likely have to try a different laptop.

Also you don't have to be afraid to crank your bike as it will run fine... Just won't be near as fast.
 

·
Registered
Joined
·
167 Posts
Discussion Starter #11
Thanks Shan... That sounds like it could be the problem... I check it out.

I'm afraid to start it because I changed the cams as well as the 840 kit... Muzzy says that I've got to run the engine at 2000 RPM for the first 15 minutes. I don't want to screw up the break-in.




I tried to call Todd today, but he was busy... Amber said he'd call me, but he never got around to it.... I'll try again tomorrow.
 

·
Registered
Joined
·
3,999 Posts
Thanks Shan... That sounds like it could be the problem... I check it out.

I'm afraid to start it because I changed the cams as well as the 840 kit... Muzzy says that I've got to run the engine at 2000 RPM for the first 15 minutes. I don't want to screw up the break-in.




I tried to call Todd today, but he was busy... Amber said he'd call me, but he never got around to it.... I'll try again tomorrow.
Amber e-mails me people to call and she never gave me your number. Please try again today or e-mail directly and I will call you.

[email protected]
 

·
Registered
Joined
·
3,999 Posts
Thanks Shan... That sounds like it could be the problem... I check it out.

I'm afraid to start it because I changed the cams as well as the 840 kit... Muzzy says that I've got to run the engine at 2000 RPM for the first 15 minutes. I don't want to screw up the break-in.




I tried to call Todd today, but he was busy... Amber said he'd call me, but he never got around to it.... I'll try again tomorrow.
Just looked thru deleted e-mails. There was one from amber to call you and I did. Went to voice mail. Can't remember if it was you or another guy but I left voicemail for one and the other was full or some other message, I can't remember.
 

·
Registered
Joined
·
167 Posts
Discussion Starter #14
Thanks for all you help guys...

Turns out that my plug on the MSD was all corroded and wouldn't make a connection with the plug. I soaked in some Isopropyl alcohol on the contacts and it cleaned it up enough I could make a connection.

Now I just got to plug it back in and see what happens.

Big thanks to Todd for his help today. Another example of a supporting vendor helping out a customer after sale.

Oh and you don't have to have your MSD plugged in to connect to the laptop. The USB powers the MSD like a camera or cell phone.

Stay tuned... I'll be starting it up tomorrow night. YAHOO!
 
1 - 15 of 15 Posts
Top