Teryx HQ banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I purchased a Teryx yesterday and my wife and son road for about three hours the parked when I went to move there is a knocking sound coming from Cvt area. I removed cover the belt is ok. I am new to this type of machine and would appreciate any advice or ideas. It also jerks a little when u try and drive it.
This was also posted in member introductions.sorry.
Thanks for any help

Robbie.
 

·
Registered
Joined
·
9 Posts
What model did you buy, is it a 2 seat or a four seat? could you explain the knocking sound?
Off the top of my head it sounds like it could be a burned belt. the kawasaki belts are very good and I haven't burned one on the teryx with all of the failsafes, but I did burn one on my prairie using it to push dirt. It would make a knocking/ chattering sound when the sheaves hit the narrower burned spot. I had this problem allot on Polaris snowmobiles also. In my experience letting my kids drive the teryx was harder on the belt than anything I have done. if they feather the throttle to much, revving the engine but not getting the machine moving they could damage a belt quickly. remember that once you are moving the belt doesn't slip but when you start out it does slip until the machine moves.
 

·
Registered
Joined
·
7 Posts
There is a pretty thorough thread in the forum about CVT noises, especially at low speed. Me, and many others, experience similar 'peculiarities', so it's apparently something that's engineered in; annoying but not necessarily harmful. Other members have offered suggestions and partial solutions, but no sure-thing repair. Surf the phrase"clunking noise" around the forum. You'll find more info.
 
1 - 4 of 4 Posts
Top