Teryx HQ banner

1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Well I have a 2008 Teryx... Uni filter, Dynatek CDI box installed and was running great till a hill climb and blue smoke! Motor stalled and didn't want to start. At shop performed a break down and replaced exhaust with Muzzy's and installed new dynatek coils and new plugs. Also installed the Hunterworks STOP kit while here. Motor cranks over with an occasional back fire but doesn't start. Fuel filter full and fuel pump is pumping into carbs. I am getting spark to both plugs. All fuses are good.

Ok just returned everything back to stock (CDI, Coils) and still no start :banghead:
Suggestions????
 

·
Registered
Joined
·
85 Posts
Hi

Bad deal for the the Christmas vacation! Did you check for compression and maybe the valves need adjustment? I have a 08 Teryx and it has done the smoke thing 2 or 3 times but has started each time. Were you running it hard meaning full throttle? You may want to check the air filter one time that mine smoked it plugged the air filter with oil and no start..Hope this gives you some where to start.
 

·
Moderator
Joined
·
383 Posts
If you have fuel and spark but no fire except for occasional backfire sounds like it needs valve adjustment or maybe something happened with the cam timing or the cams are worn out perhaps. How many hours on machine and if it blows smoke has it ever been run low on oil?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
If you have fuel and spark but no fire except for occasional backfire sounds like it needs valve adjustment or maybe something happened with the cam timing or the cams are worn out perhaps. How many hours on machine and if it blows smoke has it ever been run low on oil?
Well I returned everything back to stock cranked a few more times and it finally started. Seemed like it needed to clean out.:confused: Anyways, let it run for about 10 minutes and revved it up here and there. I then put the Dynatek CDI and Coils back on one at a time and the darn thing runs like a champ. The Teryx has 80 hours on it and it has never been ran low/without oil. The backfire is gone and the motor runs really smooth. Weird crap!
 

·
Registered
Joined
·
85 Posts
sounds good that it cleaned out but I would clean the air filter and air plenum to make sure everything is clean. I think you said you installed a oil catch can. Should help. Watch that you don't over fill crankcase and drive it.:wave:
 
1 - 5 of 5 Posts
Top