Teryx HQ banner

1 - 3 of 3 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
Has anyone added one? I got my voltmeter, fuel gauge, and trail tech in, so the last thing i was thinking would be oil pressure. Let's see what you got!
 

·
Registered
Joined
·
24 Posts
Hey Ultimate1, I added autometer temp and oil gauges a couple of months ago. The gauges and sending units were ordered online. I was concerned with threads not mathcing due to vehicle with metric threads, but it was not a problem. The temp guage works flawlessly, but oil pressure has been a different story. The sending unit was large and difficult to get into the same location as the stock one; suceeded with baby steps and bloody knuckles. When I first fired it up the gauge pegged and stayed that way until warmed up. I was shocked the Teryx ran higher oil pressure than my 0-100psi gauge was reading. While running hard it would be in the high 90's to pegged on the gauge and then back to 40-50 at idle. The owners manual states something like 80psi and that sounds more appropriate, so I'm not sure while I'm getting such high readings. Holloween weekend I noticed some oil dripping and when investigated found that I actually blew out a small hole in the sending unit. The sending unit was only rated for 0-100psi and I'm hoping that a replacment sending with higher range will stay together. I'm alright if the gauge reads pegged when running hard, my concern is low OP. I would sugest removing stock sending units and taking them to knowledgeable auto parts store to find matching threads and matching the ohm's. I ordered mine off of Egauges and got lucky. Sorry for the novel, hope this helps.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #3
OK thanks for the heads up. Auto meter makes an oil pressure gauge that goes to 150 psi, that would work. It is mechanical though. It is a full sweep face, compared to the 90 degree ones that i already have, but they are close. Anyone else put one in????
 
1 - 3 of 3 Posts
Top