Teryx HQ banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I own a 2008 teryx and I was riding it today and i shut it off to run in the house and when i came back out to start it I got nothing!! I mean the lights wouldnt even come on!!! The battery is new and the connection is good! I checked the 4 fuses located under the seat by the battery and they were fine!!! I dont know what else to do???? Please help!!!
 

·
Registered
Joined
·
189 Posts
make sure it's in Neuntril. The rod might need to be adjusted, Play with the shifter until the N light comes on with the key on the ''on'' postion. Or try pressing the brake pedal hard to start it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
The battery is not dead! It is fully charged!! I went out this morning and I got it to turn over but it was cold and shut off. I tried again and nothing. I cant even get the lights on the dash to come on when you turn the key??? Its like there is no battery in it!!
 

·
Registered
Joined
·
189 Posts
does the headlights come on?
 

·
Registered
Joined
·
85 Posts
Battery problem

I have 2 kawasaki V twins and they will not start with even low battery. It sounds like your battery is bad- try jumping it. The kawi loves a good strong battery. Good luck:)
 

·
Registered
Joined
·
189 Posts
if u jump it and it starts then the battery is junk. if u jump it and still no lights then u have a wire problem.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
I know its not the battery. I just charged it the other day. It turned over this morning fine!! Its like when I turn the key its not turning on. I mean the lights on the dash wont even light up!!! I mean even a low battery will light those up!!! Is there any way to bypass the key and just get it started so i can get it into my garage????
 

·
Registered
Joined
·
5 Posts
Discussion Starter #12
Guys i have it in neutral and I pushed the pedal to the floor. Even without being in neutral and the pedal pressed when I turn the key the dash will still light up. I cant even get the dash to light up??
 

·
Registered
Joined
·
189 Posts
your pressing the brake pedal right? I had a simular problem with mine. I would be riding and I'll shut it off, then I'll go to start it and nothing even the "N" would not come on. But I moved the shifter to H slowly and the "N" came on and then it started. But if U pressed the brake pedal and crank it over and got nothing that isn't the problem.
 

·
Registered
Joined
·
85 Posts
By chance do you have a winch connected to the battery and have a bad connection between all the wires. You may have a ground problem - You may need to start tracing wiring. I know you have ruled out the battery but a battery terminal may be broken or lose. again Good Luck .
 
1 - 14 of 14 Posts
Top