Teryx HQ banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I’m new to this forum, but looking for some opinions. I have a 2013 Teryx 750 100% stock other than 27” tires. It has begun smoking and consuming oil. It doesn’t smoke at idle, only during acceleration. I did a compression check and both cylinders read 60 psi, I know there is a compression release, and a leak down test would be the best. It doesn’t seem to have lost any power, and it will start right up. I am starting to lean towards the valve seals being the issue, since the machine seems to run fine. Anybody got an idea of an estimated cost to remove heads and inspect/replace valve seals? Or would it be wiser to plan on changing valves springs and seals since the heads will be removed anyway? Sorry for the long post, I’m just puzzled. Any input is greatly appreciated. BTW, I was using Rotella T 15W-40, have since gone to Castrol 20w-50 v-twin oil.
 

·
Registered
Joined
·
4 Posts
I’m new to this forum, but looking for some opinions. I have a 2013 Teryx 750 100% stock other than 27” tires. It has begun smoking and consuming oil. It doesn’t smoke at idle, only during acceleration. I did a compression check and both cylinders read 60 psi, I know there is a compression release, and a leak down test would be the best. It doesn’t seem to have lost any power, and it will start right up. I am starting to lean towards the valve seals being the issue, since the machine seems to run fine. Anybody got an idea of an estimated cost to remove heads and inspect/replace valve seals? Or would it be wiser to plan on changing valves springs and seals since the heads will be removed anyway? Sorry for the long post, I’m just puzzled. Any input is greatly appreciated. BTW, I was using Rotella T 15W-40, have since gone to Castrol 20w-50 v-twin oil.
Hi i am having the same problem and just replaced my valve seats and still having the save issue have you found a solution?
 

·
Registered
Joined
·
4 Posts
Ok keep me posted please i dont want to tear down the whole bike again if that doesn't fix it. I feel I should of just done that already since I was so deep at that time.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I feel your pain, I have been scratching my head for several months, hopefully this is the fix, other than the consumption and a little smoke, it ran fine.
 

·
Registered
Joined
·
4 Posts
I know it i really didn't think it was rings because of how it doesn't smoke all the time and all the power it still has. Definitely keep me posted. The only other thing I saw was a stop oil kit sold by hunterworks but I didn't like the idea of that. I only have 187 hrs on my teryx it. I just don't like the idea that it needs that when it didn't before and I have friends with alot more hours and miles that this never happened to. Its puzzling.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I know it i really didn't think it was rings because of how it doesn't smoke all the time and all the power it still has. Definitely keep me posted. The only other thing I saw was a stop oil kit sold by hunterworks but I didn't like the idea of that. I only have 187 hrs on my teryx it. I just don't like the idea that it needs that when it didn't before and I have friends with alot more hours and miles that this never happened to. Its puzzling.
The siphon break is for 2009-2010 and older, I have a 2013, and they were supposed to have fixed that issue, plus, the only way to know if you needed that was if there is oil burping into your breather box.
 

·
Registered
Joined
·
4 Posts
Ahh gotcha yes I have a 2013 also all stock besides snorkel and 28 inch tires so we are pretty much the same
 
1 - 8 of 8 Posts
Top