Teryx HQ banner

1 - 10 of 10 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
Ok just got teryx home, has anyone had any issues with the The CVT Belt Protection System in muddy situations? I don't know if it's the same as on the Brute force 750 but I know a couple that went into limp mode and were done for the weekend, dealer wanter $250 to reset system but w found out how to use the jumper and ignition code to reset. Buddy finally disabled it completly. Would like to know if should be finding the code for the Teryx?
 

·
Registered
Joined
·
66 Posts
i had my belt light come and go into limp mode once. it was when i was trying to back up a hill in high in 4x4. i just stopped giving it gas belt light went off so i dropped into low and backed right out and have never had a problem sense. me personnally i like the belt protection mode and would not disable it.
 

·
Registered
Joined
·
86 Posts
Mine went off last week when we were rock crawling on a steep hill. I was trying to go up a steep incline over some large tree roots (they were huge) but my rig was't making any ground. It was just sitting in the same spot. The roots were slippery but as soon as my wheels quit spinning, I was still on the gas and the "belt" light began flashing. I just let off, backed down the hill, and the light went off. It happened again on another steep incline with large rocks. I could smell the belt both times. As soon as it goes on, just let off and it should reset itself. It seems like if your giving it gas and it's under a load, yet it's not really moving, the light my come on and it may go into the protection mode to save the belt. I would't disable it, but that's just mu opinion.
 

·
Registered
Joined
·
62 Posts
Discussion Starter #7
Ssounds like they may have addressed the problem, when my buddys went into limp mode it didn't reset and he was back 10 miles in the muskeg and bush, said they did a lot of winching to get the brute force out. I'll leave it enabled and give it a go.
 

·
Registered
Joined
·
3,999 Posts
I don't know anything about the brute, I was thinking it has a actually device on or near the belt but on the Teryx it is all electronic.

What happens is the ECU or CDI gets a signal from the crank position sensor and one from the speed sensor and it knows that if the rpm is up but the ground speed is not up then the belt is slipping so it limps, as soon as they are within specified range it works normal.

I have not dug into it but I am not sure how to disable it.

I'm still a Teryx Guru want to be!!
 

·
Registered
Joined
·
174 Posts
i had my belt light come and go into limp mode once. it was when i was trying to back up a hill in high in 4x4. i just stopped giving it gas belt light went off so i dropped into low and backed right out and have never had a problem sense. me personnally i like the belt protection mode and would not disable it.
Just wondering what kind of Teryx you have with a low and high revers? If I had low and high revers I dont think would ever try to "back up a hill in high in 4x4" I would always use low revers if I had it!
 

·
Registered
Joined
·
66 Posts
4x4 sorry about that one noticed after i wrote that. i was in high going forward got pinned against a tree light came on then placed it in reverse and backed right out. my bad. sorry for the confussion.
 
1 - 10 of 10 Posts
Top