Teryx HQ banner

1 - 20 of 23 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have been out with the Muzzy exhaust and rejetting 4 times now. Each time I have had problems with the tranny popping out of gear and into neutral. I took it to the dealer and they said it was just the linkage adjustment. So that was that until we took it out the next weekend to the dunes. (Note all of out riding this summer has been in the dunes). My wife had good luck with it, then when I go out I put it through its paces. It jumped out again. So I take it back to camp and readjust, problem fixed. Then a little later same thing. So now I will bring my tools in the glove box to fix while out. My buddy with his new rhino is calling me"T-Wrench". Has anyone else had this issue. If so how did you fix other than jamming it up the dealers"""""". There are only a few things in the maintenance manual that says can make this happen and the linkage is the easiest, the rest is internal. It typically happens while under pressure and you can only adjust so much until you grind going into drive.
 

·
CommanderTalk.com
Joined
·
2,799 Posts
My friend, this is an issue I have not run into. When you spoke to the dealer did they simply tell you to adjust the linkage or did they do anything?

Maybe it is something more serious than the linkage and may require a trip to the dealer for warranty work?

I know this is not the answer you want, however, I just do not know.
 

·
Registered
Joined
·
1,029 Posts
I have been out with the Muzzy exhaust and rejetting 4 times now. Each time I have had problems with the tranny popping out of gear and into neutral. I took it to the dealer and they said it was just the linkage adjustment. So that was that until we took it out the next weekend to the dunes. (Note all of out riding this summer has been in the dunes). My wife had good luck with it, then when I go out I put it through its paces. It jumped out again. So I take it back to camp and readjust, problem fixed. Then a little later same thing. So now I will bring my tools in the glove box to fix while out. My buddy with his new rhino is calling me"T-Wrench". Has anyone else had this issue. If so how did you fix other than jamming it up the dealers"""""". There are only a few things in the maintenance manual that says can make this happen and the linkage is the easiest, the rest is internal. It typically happens while under pressure and you can only adjust so much until you grind going into drive.
I have had to adjust my linkage 2 times, but I have never had it pop out of gear. Your dealer needs to make this right IMHO.
 

·
Registered
Joined
·
5 Posts
Not here to scare you, just additional info, because the internal issue is obviouslu big $.

If the linkage is adjusted properly it should not slip out, this is simple. There is a slight detent, bump ,felt when the selector shaft is in the correct position, one bump for each position, L, H, N etc. Check the position of the selector handle is in the grove which it belongs in. The link rod should line up with the pivot points.

If this is all ok, I'm afraid you may need to look internally.

If there is a rounded dog on one of the gears or a bent shift fork this will allow the gear to slip out of position (or the bent fork never put the gear in the correct position) . If this is the case, when you adjust the linkage it may be ok until the load on the faulty component allows the gear to move out of position.

When this happens it will further damage the internals and likely goon up your adjustment as the linkage was forced from it's desired position under load.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
I think you are right. I have readjusted many of times and it takes care of it for a while. But after the last time I had adjusted, I determined that something more than an adjustment is wrong. So I am going to take it to the dealer again and have them make it right. The first time they had just adjusted, I will make them look harder into it this time. Do think since I had brought it in there prior to the warranty being expired, that it would extend for this had happened prior to the expiration of the warranty?
 

·
CommanderTalk.com
Joined
·
2,799 Posts
Do think since I had brought it in there prior to the warranty being expired, that it would extend for this had happened prior to the expiration of the warranty?
That is going to be up to the dealer my friend...do I think they should, absolutely, do I think they will, well that is really hard to say.

Please do let us know what it is as it could potentially help someone in the future. Best of luck my friend!
 

·
Premium Member
Joined
·
3,999 Posts
Let me throw something in.

When I was trying to lock out the CVT, I didn't have the bolts in the front tube going across from one seat to the other with the shifter mechanism attached, this caused slack and mine did the same thing. I'm sure you parts are all there but do you suppose that bar is loose?

Todd
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
I wouldnt think so, but I have not checked the tightness of all the hardware on the shifter. I will need to read further in to the manual to see if there is something with the shifter that is throwing it out of gear.
 

·
Registered
Joined
·
79 Posts
Hey Guys as much as I hate to say it I'm in the same boat, this weekend I went out to Glamis for are yearly guys trip and man did I ever have problems with my Teryx. First off my Teryx wouldn't start unless it was in between N and R, Then my jetting that I got from Dyna jet was way off it melted the cover plastics under my ruv and the top of it also discolored the nice Muzzys pipes. Then onces I had all that done I went to Osmoblie and right when I got almost to the very top it pop out of gear so I waited till the rpm went down and tried again then it would happen again and again, then I had to had to force the handle and bent the lever to keep it in reverse to get it to turned around. So I tried a couple of more times and still no success so I had to fish it from one side to the other till I finally made it. Well it to keep a smile on all our faces going back from the hill to the Flats I was on all the Rzr and rhino's my Teryx was OK until it was under a heavy load which made it pop. I call the dealer were I got it from they said to take it in that they've been having issues with linkage and they were not sure if it was the tranny or mechanical problems but that they would look at it. I truly hope this is a one time fix, but I feel from other commets I've read this could be a plague, nothing more upsetting then loading up kids and wife and going to Glamis only to disappoint the little ones.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
I am sort of glad to here that it is not me. This may show the dealers/ kawi that they need to fix our issues and there's to come. The kawi over the rhino is hands down a better ride for power and just feel. I am hoping this is an easy fix . But I am tired of it as well. My wife drives it with my 3.5 year old daughter in her car seat . So when I turn back and she is in a bowl with her hands up in the air. I get kind of pissed. I have to go over tear it down , break out the misc tools needed and adjust the linkage over and over again in a three day weekend. "Good Fun". We'll get it fixed.
 

·
Registered
Joined
·
79 Posts
Dealer called me today and said it's ready to pick and that it was a adjustment problem and not worry, they say that because before I even rode my Ruv it had rubbed a hole in the front brake line and cut it. So I made a big deal about that and they said not to worry they would fix it(safety wire). Well I spoke to the head mechanic and he said it was out of line and they fixed it, I told him that I've heard from many other people as well as their owner of the dealership having issues with it and how could they assure me it was fixed. To make a long story short he said it would be an hours labor (80$) my Teryx is 7 weeks new and if it has the same problem they would look more into it. Not happy but I guess thats what this site is for, to resolve all the little issue and leave the big ones to corporate America ,LOL were all owner of AIG insurance.

Roman
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
You need to make sure that that you carry a small pair of vise-grips and a 10 or 12 mm wrench with a crescent wrench to adjust in the field/ dunes/ trails. Make surev you have it. I will tell you what happens next week when they look into mine. I am going to push them into fixing the issue, I am not going to have to be MR. "T-Wrench" anymore. If I want wanted to be MR. Goodwrench I would have bought a VW or Corvaire!!!
 

·
Registered
Joined
·
79 Posts
Hey crew I got my Teryx back on Wednesday from the dealer and he said it was a Small miss aliment and not to worry that it was OK, Dealers and Lawyers scare me when they say don't worry we'll take care of it. Yea but it's at our expense. So I paid my 80$ service charge since they said this was a maintnces issue not a warranty issue WOW. So if there's anything we can do to track this issue till it's resolved would be monies saved since all of us are Teryx owners and would like to enjoy our rides not wrench on them. Any info anyone has that we could use to pin point the problem would be great. Just a thought, how are you guys transporting your ride, it's seems to me that the parking brake may may not something to do with the linkage. It's a big machine and all the weight is on the brakes maybe we've left it in gear a time or two and these are super sensitive and they bind on each other, Once again I'm just thinking out load to brain storm and try to narrow down till we fix this linkage problem.

Roman
 

·
Premium Member
Joined
·
430 Posts
Popping Out of Gear

I had this same issue this weekend my question is has the linkage adjustment taken care of the problem or have there been repeat visits to the dealer.
 

·
Registered
Joined
·
79 Posts
I went out this weekend for the first time, since my issues with the linkage. I must say I was very impressed with my Teryx hands down I saw a ton of sxs AND HIGH PERFORMANCES ones and mine with my paddles from Fullerton were able to climb all the hills around and had plenty of power. I went up Old's no problem and it seems my linkage problem may be resolves I really hope. I can't say enough about these machines I had a blast, had my girlfriend and her son and a big cooler and we went up all the hills so smooth, I have a Duncan Racing built motor with suspension and cdi the works never even touched it this weekend just sat there and got dusty. I'm very happy with this machine and with the way it handled and the long travel suspension was just awesome I ran full speed thru the whoops wide opened and it just soaked up all the bumps. Can't wait till next time.

Roman
 

·
Registered
Joined
·
14 Posts
Discussion Starter #16
I just took mine in again this last weekend, they finally got back to me on friday(after asking me to approve 350-700 in labor and me declining , telling them they need to make it right). They found that the crank case is cracked. I am assuming that it is above the oil filler spout, like the other picture I saw on this or the other forum. I took it in on 7-30-08 with about 40 hours on it and they said it was the linkage, but due to it popping out of gear so much, it has finally cracked the case due to poor trouble shooting of the Kawi technician. The one thing is that they need to take care of all of this. I will be finding out on Monday the 10th on the outcome.
 

·
Registered
Joined
·
11 Posts
poping out of gear ???

went out riding this weekend and got it out of the truck and went up a hill and bam popped out of gear and after the linkage was way out of alighnment seen a few posts on this just wondering what the outcome was did it stop or get worse after a few adjustments??? help:mad:
 

·
Registered
Joined
·
137 Posts
Are these machines having this problem 08's or 09's???????
 

·
Registered
Joined
·
165 Posts
I am having adjustment problems as well. After a hard landing i could hear the gears grinding.. I have adjusted twice now...I want to know why it keeps changing!!
 

·
Registered
Joined
·
54 Posts
Hey crew I got my Teryx back on Wednesday from the dealer and he said it was a Small miss aliment and not to worry that it was OK, Dealers and Lawyers scare me when they say don't worry we'll take care of it. Yea but it's at our expense. So I paid my 80$ service charge since they said this was a maintnces issue not a warranty issue WOW. So if there's anything we can do to track this issue till it's resolved would be monies saved since all of us are Teryx owners and would like to enjoy our rides not wrench on them. Any info anyone has that we could use to pin point the problem would be great. Just a thought, how are you guys transporting your ride, it's seems to me that the parking brake may may not something to do with the linkage. It's a big machine and all the weight is on the brakes maybe we've left it in gear a time or two and these are super sensitive and they bind on each other, Once again I'm just thinking out load to brain storm and try to narrow down till we fix this linkage problem.

Roman
Interesting thought, I have towed/ trailered many offroad machines and always opted to tie em down good and not carry them with the trans in gear. Never had E-brakes on the cars, But the rocking that they do on the trailer always made me think to put it in neutral and not lean on the gears.
 
1 - 20 of 23 Posts
Top