Teryx HQ banner

1 - 4 of 4 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
sup guys ,i was just wondering when tuning do u use a oyxgen sensor or just run the fuel ratio gauge up the exaust .i notice that my muzzy exaust have places for o2 sensor but didnt come frome the factory. been reading up on this msd and it was saying somyhing bout a o2 reading to really tune. im trying to learn how to tune this thing my self.and also does the temp sensor that runs the fan have anything to do with it running rich .fan hasnt been werking correct ,i can unplug it and it werks plug it back up and it quits. havent been able to get rid of richness ,ive took the fuel way back and still rich there has to be cold start sensor or somthing..i just want to figure this fuel injection crap out:D thanks for any info
 

·
Registered
Joined
·
62 Posts
Discussion Starter #3
kawasaki sucks,,,,,,,,,,,,,,,,, 5 grand and cant stop it from getting hot. fixing to go back stock ,to hell with all these kits that are supose to be all that if there not tunable why have it ,to all u looking into kits better off stock,got 3000 miles stock 300 on new kit,3 main reasons it want take off out of the hole, it gets hot every time i ride it ,and it want leane down take the fuel to the negatives and still rich.i give up.shoulda bought a rino and rode in the back.,at least there dependable.just my 2 cents.
 

·
Registered
Joined
·
3,999 Posts
We don't have trouble with running hot with engine kits, I only use std bore kits though.

Tuning it would be easy, give me call and since your in AL I think then it is not too far to come over to let me tune it for you.

Also we have a fan bypass switch to do away with the querky stock set up
 
1 - 4 of 4 Posts
Top